Compatibility with Microsoft Dynamics CRM 2016

Applies to: Microsoft Dynamics CRM 2016

Introduction


This article focuses on recent and upcoming compatibility testing for Microsoft Dynamics CRM 2016. It also focuses on the most common compatibility questions that are processed by Microsoft Dynamics Technical Support. This article does not indicate Microsoft Dynamics CRM compatibility for all products. This article supplements the information in the Microsoft Dynamics CRM Implementation Guide.

More Information


The products that have a status of "TBD" are being considered for future compatibility. When the testing of these products is complete, this article will be updated to show the revised status values.

Microsoft Dynamics CRM 2016

The following products have been tested or are currently being tested for compatibility with Dynamics CRM 2016. The Minimum CRM version and CRM build number fields list the minimum Microsoft Dynamics CRM version that has been tested and that is compatible with the listed product.
 
Product Minimum CRM version CRM build number Status
.Net Framework 4.0 RTM 8.0.0.1088 Compatible
.Net Framework 4.5 RTM 8.0.0.1088 Compatible
.Net Framework 4.5.1 RTM 8.0.0.1088 Compatible
.Net Framework 4.5.2 RTM 8.0.0.1088 Compatible
.Net Framework 4.6 RTM 8.0.0.1088 Compatible
Apple Safari (latest publicly released version) running on Mac OS X 10.8 (Mountain Lion), 10.9 (Mavericks), 10.10 (Yosemite), or Apple iPad RTM 8.0.0.1088 Compatible
Active Directory Federation Services in Windows Server 2008 (AD FS 2.0) RTM 8.0.0.1088 Compatible
ActiveDirectoryFederationServicesinWindowsServer2008 R2 RTM 8.0.0.1088 Compatible
Active Directory Federation Services in Windows Server 2012 RTM 8.0.0.1088 Compatible
Active Directory Federation Services in Windows Server 2012 R2 RTM 8.0.0.1088 Compatible
Active Directory Federation Services in Windows Server 2016  Dynamics 365   Not Compatible
Azure virtual machines (support for Microsoft Azure virtual machines) RTM 8.0.0.1088 Compatible - Requires Azure Premium Storage
Citrix (XenApp) 6.5 RTM 8.0.0.1088 Compatible
Citrix (XenApp) 7.0 up to 7.18 RTM 8.0.0.1088 Compatible
CRM 2011 for Outlook Client - - Not Compatible
CRM 2013 for Outlook Client -   Not Compatible
CRM 2015 for Outlook Client (No Offline Capabilities) RTM 8.0.0.1088 Compatible
CRM 2016 for Outlook Client RTM 8.0.0.1088 Compatible
Exchange Online (E3 SKU Only) RTM 8.0.0.1088 Compatible
Exchange Server 2003 - - Not Compatible
Exchange Server 2007 - - Not Compatible
Exchange Server 2010 Standard RTM 8.0.0.1088 Compatible
Exchange Server 2010 Enterprise RTM 8.0.0.1088 Compatible
Exchange Server 2013 Standard RTM 8.0.0.1088 Compatible
Exchange Server 2013 Enterprise RTM 8.0.0.1088 Compatible
Exchange Server 2016 RTM 8.0.0.1088 Compatible
Google Chrome (latest publicly released version) running on Windows 10, Windows 8.1 or Windows 8, or Windows 7, or Google Nexus 10 tablet RTM 8.0.0.1088 Compatible
IIS 7.0 - - Not Compatible
IIS 7.5 - - Not Compatible
IIS 8.0 RTM 8.0.0.1088 Compatible
IIS 8.5 RTM 8.0.0.1088 Compatible
IIS 10.0 RTM 8.0.0.1088 Compatible
Internet Explorer 7 - - Not Compatible
Internet Explorer 8 - - Not Compatible
Internet Explorer 9 - - Not Compatible
Internet Explorer 10 on Windows 8, or Windows 7 (no longer supported) RTM 8.0.0.1088 Compatible
Internet Explorer 11 on Windows 10, Windows 8.1, or Windows 7 RTM 8.0.0.1088 Compatible
Microsoft Dynamics CRM 2015 Email Router - - Not Compatible
Microsoft Dynamics CRM 2016 Email Router RTM 8.0.0.1088 Compatible
Microsoft Edge on Windows 10 RTM 8.0.0.1088 Compatible
Microsoft SharePoint 2007 - - Not Compatible
Microsoft SharePoint 2010 SP2 (all editions) RTM 8.0.0.1088 Compatible
Microsoft SharePoint Foundation 2013 RTM 8.0.0.1088 Compatible
Microsoft SharePoint 2013 RTM 8.0.0.1088 Compatible
Microsoft SharePoint 2016 (Server-based Integration only) Dynamics 365 8.2.0.0749 Compatible
Microsoft SQL Server 2005 - - Not compatible
Microsoft SQL Server 2008 (all versions) - - Not compatible
Microsoft SQL Server 2008 R2 (all versions) - - Not compatible
Microsoft SQL Server 2012 Enterprise SP1 (x64) RTM 8.0.0.1088 Compatible
Microsoft SQL Server 2012 Business Intelligence SP1 (x64) RTM 8.0.0.1088 Compatible
Microsoft SQL Server 2012 Standard SP1 (x64) RTM 8.0.0.1088 Compatible
Microsoft SQL Server 2012 Developer SP1 (x64)(for non-production use only) RTM 8.0.0.1088 Compatible
Microsoft SQL Express 2012 (x86 only) (CRM for Outlook 2016) RTM 8.0.0.1088 Compatible
Microsoft SQL Server 2014 Enterprise with Service Pack 2 (x64) RTM 8.0.0.1088 Compatible
Microsoft SQL Server 2014 Business Intelligence with Service Pack 2 (x64) RTM 8.0.0.1088 Compatible
Microsoft SQL Server 2014 Standard with Service Pack 2 (x64) RTM 8.0.0.1088 Compatible
Microsoft SQL Server 2014 Developer with Service Pack 2 (x64) (for non-production use only) RTM 8.0.0.1088 Compatible
Microsoft SQL Server 2016, Developer, with Cumulative Update 2 (CU2) (for non-production use only) Must have updates installed from Update Catalog RTM 8.0.0.1088 Compatible
Microsoft SQL Server 2016, Standard with Cumulative Update 2 (CU2) Must have updates installed from Update Catalog RTM 8.0.0.1088 Compatible
Microsoft SQL Server 2016, Enterprise with Cumulative Update 2 (CU2) Must have updates installed from Update Catalog RTM 8.0.0.1088 Compatible
Mozilla Firefox (latest publicly released version) running on Windows 10, Windows 8.1, Windows 8, or Windows 7 RTM 8.0.0.1088 Compatible
Office 2003 - - Not Compatible
Office 2007 - - Not Compatible
Office 2010 (Cached-Exchange Mode Only) RTM 8.0.0.1088 Compatible
Office 2013 (Cached-Exchange Mode Only) RTM 8.0.0.1088 Compatible
Office 2016 (Cached-Exchange Mode Only) RTM 8.0.0.1088 Compatible
Office 365 (Cached-Exchange Mode Only) RTM 8.0.0.1088 Compatible
Windows 7 Service Pack 1 (for clients) RTM 8.0.0.1088 Compatible
Windows 8.0 (for clients) RTM 8.0.0.1088 Compatible
Windows 8.1 (for clients) RTM 8.0.0.1088 Compatible
Windows 10 (for clients) RTM 8.0.0.1088 Compatible
Windows Server 2003 - - Not compatible
Windows Server 2008 (all versions) - - Not compatible
Windows Server 2008 R2 (all versions) - - Not compatible
Windows Server 2012 Foundation - - Not compatible
Windows Server 2012 Essentials - - Not compatible
Windows Server 2012 Datacenter RTM 8.0.0.1088 Compatible
Windows Server 2012 Standard RTM 8.0.0.1088 Compatible
Windows Server 2012 R2 Datacenter RTM 8.0.0.1088 Compatible
Windows Server 2012 R2 Standard RTM 8.0.0.1088 Compatible
Windows Server 2016 Dynamics 365 8.2.0.0749 Compatible
Windows Small Business Server - - Not compatible
Windows Vista (for clients) - - Not Compatible


For a list of mobile supportability with Microsoft Dynamics CRM 2016, please see the following link:

CRM for Tablets, CRM for Phones, and Tablet Browser support for Microsoft Dynamics CRM


Notes
  • The CRM for Outlook client does not support Outlook configured in Online for tracking or synchronization (non-Cached Exchange mode)
For more information about System Requirements, see the System Requirements and Required Components section of the Microsoft Dynamics CRM 2016 Implementation Guide.