User can't sign in or sees the wrong interface after a mailbox move

Original KB number:   3127342

Symptoms

In a coexistence environment, you successfully move a user mailbox from Exchange Server 2010 to Exchange Server 2013 or Exchange Server 2016. However, when the user tries to sign in to the mailbox in OWA or Outlook on the web, the user receives the following error message:

You weren't able to sign in because the mailbox is being moved. You won't be able to access until the move is complete. Please wait and try again later.

Additionally, if the user can sign in to the mailbox successfully, the page may show the interface of OWA for Exchange Server 2010.

Cause

This problem occurs because the client and the OWA application pool on Client Access servers (CAS) in Exchange Server 2013 or Exchange Server 2016 keep the cookies that are generated by Exchange Server 2010. Therefore, the user is proxied to an Exchange Server 2010 CAS.

Workaround - Method 1

Have the user wait at least 30 minutes after the mailbox is moved before they sign in to OWA or Outlook on the web.

Workaround - Method 2

Clear the cookies on the client and on the server that is running Exchange Server 2013 or Exchange Server 2016. To do this, follow these steps:

  1. Clear browser cookies on the client.

    For more information, see Delete and manage cookies.

  2. Clear the cookies on the server. To do this, restart the MSExchangeOWAAppPool application pool by running the following command on the server:

    Restart-WebAppPool MSExchangeOWAAppPoolnull