"The option you chose isn't available" error when a user tries to set up automatic replies or an email signature in Outlook on the web

PROBLEM

When a user tries to set up automatic replies or an email signature in Outlook on the web, they receive the following error message:
The option you chose isn't available.
Additionally, some options are missing under Settings.

CAUSE

This issue occurs if the MyBaseOptions role isn't enabled on the role assignment policy that's assigned to the mailbox. 

SOLUTION

To resolve this issue, follow these steps:
  1. Do one of the following, as appropriate for your situation:
  2. Run the following command to identify the role assignment policy that's assigned to the mailbox:
    Get-mailbox <mailboxUPN> | FL *RoleAssignmentPolicy 
  3. Open the Exchange admin center, click permissions, and then click user roles.
  4. Select the role assignment policy that you determined in step 2, and then click Edit.
  5. Select the MyBaseOptions check box, and then click save.

MORE INFORMATION

Still need help? Go to Microsoft Community or the Exchange TechNet Forums.
Properties

Article ID: 3145373 - Last Review: Dec 28, 2016 - Revision: 1

Microsoft Exchange Online, Exchange Server 2016 Enterprise Edition, Exchange Server 2016 Standard Edition, Microsoft Exchange Server 2013 Enterprise, Microsoft Exchange Server 2013 Standard Edition, Microsoft Exchange Server 2010 Enterprise, Microsoft Exchange Server 2010 Standard

Feedback