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Symptoms

Assume that a member of a distribution list is also a member of a Response Group service (RGS) agent group in a Microsoft Lync Server 2013 environment. When the member's SIP address is changed, all related changes are blocked from synchronizing from Active Directory to the RGS database. Also, event ID 31128 is logged as follows:


Additionally, users who were recently added to the RGS agent group experience the following issues:

  • Newly added users don't receive the 'You were added as an agent' notification.

  • Calls that are made to the RGS workflow aren't routed to the newly added RGS agent.

Cause

This issue occurs because the SIP address change prevents RGS from referencing the agent. However, the RGS database indexes agents by using their SIP addresses.

Resolution

To fix this issue, apply the April 2016 cumulative update 5.0.8308.956 for the Lync Server 2013, Response Group Service.

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