Can't export PST files after you run an eDiscovery search in Office 365 Dedicated/ITAR (vNext)

Symptoms

When you try to export PST files after you run an eDiscovery search in Microsoft Office 365 Dedicated/ITAR (vNext), you receive an error message that resembles the following: 
Object reference is not set to an instance of an object

Cause

This issue occurs because custom Role Based Access Control (RBAC) role assignment is supported only for members of a specific group.

Resolution

RBAC role assignment can be restricted only by the memberOf attribute in Active Directory Domain Services (AD DS). All other recipient scopes trigger this failure. To resolve this issue, follow the steps at Create a custom management scope for In-Place eDiscovery searches.
Properties

Article ID: 3164137 - Last Review: May 18, 2016 - Revision: 1

Feedback