Can't set BusyOnBusy option with ActionType of VoicemailOnBusy for Exchange Online user

Symptoms

When you set the BusyOnBusy option to an ActionType of VoicemailOnBusy, you receive a "Voicemail is not enabled for Identity KatieJ@contoso.com" error message.

Cause

This issue occurs when the user's mailbox is homed in Office 365 Exchange and has a Hosted Voicemail policy instead of an Exchange on-premises UM Mailbox policy.

Workaround

To work around this issue, enable the user for BusyOnBusy with an ActionType of VoicemailOnBusy before you move the user’s mailbox to Exchange Online. Then, enable the user for a hosted voice mail policy in Skype for Business on-premises.

Note Support for this configuration is "best effort" because the VoicemailOnBusy action type was designed to support only on-premises Exchange UM deployments.

More Information

Microsoft is working on a solution to allow administrators to set BusyOnBusy options for Skype for Business on-premises users whose mailbox is homed in Exchange online.
Properties

Article ID: 3168736 - Last Review: Jun 7, 2016 - Revision: 1

Skype for Business

Feedback