November 2016 Preview of Quality Rollup for the .NET Framework 4.5.2 on Windows Vista SP2, Windows 7 SP1, Windows Server 2008 SP2, and Windows Server 2008 R2 SP (KB3195363): November 15, 2016

Applies to: Windows Vista Service Pack 2Windows Server 2008 Service Pack 2Windows 7 Service Pack 1

The November 2016 Preview of Monthly Quality Rollup for Windows Vista Service Pack 2 (SP2), Windows Server 2008 SP2, Windows 7 SP1, and Windows Server 2008 R2 SP1, includes cumulative improvements in reliability in the .NET Framework 4.5.2. We recommend that you apply this quality rollup as part of your regular maintenance routines. Before you install this update, see the "Prerequisites" and "Restart requirement" sections.

Quality and reliability improvements

ADO.NET issue resolved

Exceptions may be thrown in SqlClient during the prelogin handshake process or during MARS communication when a received TDS packet size is smaller than expected. Prelogin handshake errors will manifest as an OverflowException, and MARS errors will manifest as a generic "Physical connection is not usable" exception.

Note This update also contains cumulative updates that were released previously starting from October 11, 2016.

WPF issue resolved
Assume that a Windows Presentation Foundation (WPF) application includes a D3DImage control. You start the application, change both the size and the content of the image, and then run the image through software rendering. For example, you run the application through Remote Desktop. In this situation, memory leak occurs.

More Information


How to get this update

Method 1:
This update is available from Windows Update, as an Optional update.
Method 2:
To get the stand-alone package for this update, go to the Microsoft Update Catalog website.

Prerequisites

To apply this update, you must have the .NET Framework 4.5.2 installed, as appropriate.

Restart requirement

You have to restart the computer after you apply this update if any affected files are being used. We recommend that you close all .NET Framework-based applications before you apply this update.

Applies to

This article applies to the following operating systems that have the .NET Framework 4.5.2 installed:
  • Windows Vista SP2
  • Windows Server 2008 SP2
  • Windows 7 SP1
  • Windows Server 2008 R2 SP1