Inconsistent search results when email body contains both English and non-English characters in Exchange Server 2013

Applies to: Exchange Server 2013 EnterpriseExchange Server 2013 Standard Edition

Symptoms


In a Microsoft Exchange Server 2013 environment, search functionality in Outlook Web App fails when you search non-English words in an email message whose body contains both non-English characters (such as Chinese or Japanese) and English characters.

Cause


When both Chinese-Japanese-Korean (CJK) and non-CJK languages are detected by Outlook Web App search, the first one is used instead of the CJK language. This may cause incorrect search results.

Resolution


To fix this issue, install Cumulative Update 15 for Exchange Server 2013 or a later cumulative update for Exchange Server 2013.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References


Learn about the terminology that Microsoft uses to describe software updates.