MS16-155: Description of the Security and Quality Rollup .NET Framework 3.5.1, 4.5.2, 4.6, 4.6.1, and 4.6.2 updates for Windows 7 and Windows Server 2008 R2: December 13, 2016

Summary

This December 13, 2016, Security and Quality Rollup for .NET Framework 3.5.1, 4.5.2, 4.6, 4.6.1, and 4.6.2 updates for Windows 7 and Windows Server 2008 R2 resolves vulnerabilities in the Microsoft .NET Framework. A security vulnerability exists in the .NET Framework which could allow an attacker to access information at rest that should be defended by cryptographic mechanisms. This update fixes the way the framework handles the key, and therefore defends the data while at rest appropriately. To learn more about this vulnerability, see Microsoft Security Bulletin MS16-155. This update also includes cumulative .NET security updates and improvements in reliability in the .NET Framework. For more information about reliability improvements included for this configuration, see Knowledge Base article 3196686 .

Additional information about this security update

The following article contains additional information about this security and quality rollup as it relates to individual product versions. The article may contain known issue information.
  • 3205379 MS16-155: Description of the Security and Quality Rollup for the .NET Framework 4.6.2 for Windows 7 and Windows Server 2008 R2: December 13, 2016
  • 3210136  MS16-155: Description of the Security and Quality Rollup for the .NET Framework 4.6 and 4.6.1 for the .NET Framework 4.6 for Windows Vista SP2 and Windows Server 2008 SP2, and the .NET Framework 4.6 and 4.6.1 for Windows 7 SP1 and Windows Server 2008 R2 SP1
  • 3210139 MS16-155: Description of the Security and Quality Rollup for the .NET Framework 4.5.2 for Windows Vista Service Pack 2, Windows Server 2008 Service Pack 2, Windows 7 Service Pack 1, and Windows Server 2008 R2 Service Pack 2: December 13, 2016
  • 3210131 MS16-155: Description of the Security and Quality Rollup for the .NET Framework 3.5.1 for Windows 7 and Windows Server 2008 R2: December 13, 2016
How to obtain help and support for this security update

Applies to

This article applies to the following:
  • Microsoft .NET Framework 4.6, 4.6.1, or 4.6.2 when used with:
    • Windows Server 2008 R2 Service Pack 1
    • Windows 7 Service Pack 1
  • Microsoft .NET Framework 4.5.2 when used with:
    • Windows Server 2008 R2 Service Pack 1
    • Windows 7 Service Pack 1
  • Microsoft .NET Framework 3.5.1 when used with:
    • Windows Server 2008 R2 Service Pack 1
    • Windows 7 Service Pack 1
Properties

Article ID: 3205402 - Last Review: Dec 19, 2016 - Revision: 1

Feedback