Voice mail settings are missing from the Options pane in Outlook on the web in Office 365

Applies to: Exchange Online

PROBLEM


Assume that you assigned an Office 365 plan that includes Unified Messaging (UM) to a user. However, when the user opens the Options pane in Outlook on the web, the Voice mail settings are missing. 

CAUSE


This issue may occur if UM isn't enabled in the mailbox policy that's assigned to the mailbox or the MyTextMessaging and MyVoiceMail settings aren't enabled for the user role that's assigned to the mailbox.

SOLUTION


To resolve this issue, follow these steps:
  1. Make sure that UM is enabled in the mailbox policy that's assigned to the mailbox. To do this, follow these steps:
    1. Connect to Exchange Online by using the remote PowerShell. For more information, see Connect to Exchange Online PowerShell.
    2. Run the following command to identify the mailbox policy that's assigned to the mailbox:
      Get-CASmailbox <mailboxUPN> | FL *OWAMailboxPolicy 
    3. Open the Exchange admin center, click permissions, and then click Outlook Web App policies.
    4. Select the mailbox policy that you determined in step 1B, and then click Edit.
    5. Click features, click to select the Unified Messaging check box, and then click Save.
  2. Make sure that the MyTextMessaging and MyVoiceMail settings are enabled for the user role that's assigned to the mailbox. To do this, follow these steps:
    1. Connect to Exchange Online by using the remote PowerShell. For more information, see Connect to Exchange Online PowerShell.
    2. Run the following command to identify the role assignment policy that's assigned to the mailbox:
      Get-mailbox <mailboxUPN> | FL *RoleAssignmentPolicy  
    3. Open the Exchange admin center, click permissions, and then click user roles.
    4. Select the role assignment policy that you determined in step 2B, and then click Edit.
    5. Click to select the MyTextMessaging and MyVoiceMail check boxes, and then click Save.

MORE INFORMATION


If you're using the Skype for Business voice mail service with cloud PSTN, the voice mail options are not available. For more information, see Set up your voice mail.

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