Try Microsoft Edge, a fast and secure browser that's designed for Windows 10 Get started

Microsoft
  • Store
    Store home
    Devices
    • Microsoft Surface
    • PCs & tablets
    • Xbox
    • Virtual reality
    • Accessories
    • Windows phone
    Software & Apps
    • Office
    • Windows
    • Additional software
    • Windows apps
    • Windows phone apps
    Games & Entertainment
    • PC games (disc)
    • Windows digital games
    • Windows phone games
    • Movies & TV
    • Music
    Deals
    • Sale
    • Microsoft Surface deals
    • PC deals
    • Xbox deals
    More
    • Business
    • Students & educators
    • Developer
    • Gift cards
  • Products
    Software & services
    • Windows
    • Office
    • Free downloads & security
    • Internet Explorer
    • Microsoft Edge
    • Skype
    • OneNote
    • OneDrive
    • Microsoft Health
    • MSN
    • Bing
    • Microsoft Groove
    • Microsoft Movies & TV
    Devices & Xbox
    • All Microsoft devices
    • Microsoft Surface
    • All Windows PCs & tablets
    • PC accessories
    • Xbox & games
    • Microsoft Lumia
    • All Windows phones
    • Microsoft HoloLens
    For business
    • Cloud Platform
    • Microsoft Azure
    • Microsoft Dynamics 365
    • Windows for business
    • Office for business
    • Skype for business
    • Surface for business
    • Enterprise solutions
    • Small business solutions
    • Find a solutions provider
    • Volume licensing
    For developers & IT pros
    • Develop Windows apps
    • Microsoft Azure
    • MSDN
    • TechNet
    • Visual Studio
    For students & educators
    • Office for students
    • OneNote in classroom
    • Shop PCs & tablets perfect for students
    • Microsoft in Education
  • Support
Sign in
  • items in cart
items in cart

 Manage my account
 Manage my account
 Ask the community
 Contact us
 Find downloads

CV: 5SMZT6JpmIjRwMja.0

Error message when you write a file to a server from a Windows XP-based or a Windows 2000-based computer: "Delayed Write Failed"

  •  Email
  •  Print
Hotfix Download Available

The problem that the "Symptoms" section describes can occur on other versions of Windows, and the problem is documented in other Microsoft Knowledge Base articles. To troubleshoot similar problems, see the "Similar problems and resolutions" section.

Symptoms

While a client is writing a file to a server across the network, they may receive the following error message:
{Delayed Write Failed}
Windows was unable to save all the data for the file x.
The data has been lost.
This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.
To determine whether the client is experiencing the problem that is described in this article, check the event log. The event log must contain event ID 50 with a source of MrxSMB. The event contains the same text as the error message, but also contains the error status in the data section. Double-click the event, and then click Words for the data type; the last word contains the status. If the status code is c0000022 (which translates to STATUS_ACCESS_DENIED), apply the hotfix that is described in this article.

Cause

This problem occurs because the client redirector does not calculate the SMB signature properly.

Note Apply the patch to the computer that is receiving the Delayed Write error message, the client computer.

Resolution

Windows 2000

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows 2000 server service pack 1 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date Time Version Size File name
------------------------------------------------------
08-May-2002 11:10 5.0.2195.5754 371,344 Mrxsmb.sys
04-Apr-2002 16:47 5.0.2195.5535 131,984 Rdbss.sys

Windows XP

Service Pack Information

To resolve this problem, obtain the latest service pack for Windows XP. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Prerequisites

You must have Windows XP service pack 1 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version        Size     File name
------------------------------------------------------
06-Mar-2003 14:33 5.1.2600.1181 154,880 Rdbss.sys
06-Mar-2003 14:33 5.1.2600.1181 401,792 Mrxsmb.sys

Workaround

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

To work around this problem, turn off SMB signing on the server:
  1. Start Registry Editor.
  2. Locate, and then click the
    enablesecuritysignature value under the following key in the registry:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Lanmanserver\Parameters
  3. On the Edit menu, click Modify.
  4. In the Value data: box, type
    0, and then click OK.
  5. Quit Registry Editor.
  6. Stop and then restart the server service, or restart the computer.

Status

Windows 2000

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

Windows XP

This problem was first corrected in Windows XP Service Pack 2.

More Information

For more information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the following article number to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product

For more information about how to install multiple hotfixes with only one reboot, click the following article number to view the article in the Microsoft Knowledge Base:

296861 How to Install Multiple Windows Updates or Hotfixes with Only One Reboot

Similar problems and resolutions

For more information about similar problems and resolutions, click the following article number to view the article in the Microsoft Knowledge Base:

330174 Error message that you may receive when you save or move documents in Windows XP: "Delayed Write Failed"

818788 "{Delayed Write Failed}" error message when you unplug a USB 2.0 storage device

831594 "Delayed Write Failed" error message when you try to save a file or to exit OneNote 2007 or OneNote 2003

843515 Your network connection may be reset when you try to perform a file operation on a remote Windows Server 2003-based computer

870894 You receive a "Delayed Write Failed" error message in Windows XP Service Pack 2 or Windows XP Tablet PC Edition 2005

885464 SBP-2 drive stops responding when you try to write data in Windows XP

885688 Event ID 57, event ID 55, and event ID 50 may be logged when you use Windows Cluster on Windows Server 2003

890352 A program may stop responding, and event 50 and event 26 are logged, when the program tries to write data to a volume mount point on a Windows Server 2003-based computer

891194 Event ID: 26 occurs when you log off from a server that has Terminal Server enabled in Windows Server 2003 S891194

912593 Event ID 50, 26, or 57 is logged when you use HP SecurePath on a computer that is running Windows Server 2003 Service Pack 1 or an x64 edition of Windows

925269 Error message when you disconnect a removable storage device such as an SD card from a Windows XP-based computer: "Windows Delayed Write Failed"

927912 Error message and events are logged in the System log when you try to compress a large file on an NTFS volume in Windows XP, in Windows 2000, or in Windows Server 2003: "Delayed Write Failed"

If these Microsoft Knowledge Base articles do not help you resolve the problem, or if you experience symptoms that differ from those that are described in the “Symptoms” section, please search the Microsoft Knowledge Base for more information. To search the Microsoft Knowledge Base, follow these steps:
  1. Visit the following Microsoft Web site:
    http://support.microsoft.com
  2. Type the text of the error message that you received, or type a description of the problem in the Search Support (KB) text box, and then press ENTER.
Properties

Article ID: 321733 - Last Review: Feb 15, 2017 - Revision: 2

Feedback
Thanks! Your feedback will help us improve the support experience.

Support

Support

  • Account support
  • Supported products list
  • Microsoft Lifecycle Policy

Security

Security

  • Safety & Security Center
  • Download Security Essentials
  • Malicious Software Removal Tool

Contact Us

Contact Us

  • Report a support scam
  • Disability Answer Desk
  • Locate Microsoft addresses worldwide
This site in other countries/regions
Algérie - Français
Argentina - Español
Australia - English
Belgique - Français
België - Nederlands
Bolivia - Español
Bosna i Hercegovina - Hrvatski
Brasil - Português
Canada - English
Canada - Français
Chile - Español
Colombia - Español
Costa Rica - Español
Crna Gora - Srpski
Danmark - Dansk
Deutschland - Deutsch
Dominican Republic - Español
Ecuador - Español
Eesti - Eesti
El Salvador - Español
España - Español
Estados Unidos - Español
France - Français
Guatemala - Español
Hong Kong SAR - English
Hrvatska - Hrvatski
India - English
Indonesia (Bahasa) - Bahasa
Ireland - English
Italia - Italiano
Latvija - Latviešu
Lietuva - Lietuvių
Luxembourg - Français
Magyarország - Magyar
Malaysia - English
Maroc - Français
México - Español
Nederland - Nederlands
New Zealand - English
Norge - Bokmål
Panamá - Español
Paraguay - Español
Perú - Español
Philippines - English
Polska - Polski
Portugal - Português
Puerto Rico - Español
România - Română
Schweiz - Deutsch
Singapore - English
Slovenija - Slovenščina
Slovensko - Slovenčina
South Africa - English
Srbija - Srpski
Suisse - Français
Suomi - Suomi
Sverige - Svenska
Tunisie - Français
Türkiye - Türkçe
United Kingdom - English
United States - English
Uruguay - Español
Venezuela - Español
Việt Nam - Tiếng việt
Ísland - Íslenska
Österreich - Deutsch
Česká Republika - Čeština
Ελλάδα - Ελληνικά
България - Български
Казахстан - Русский
Россия - Русский
Україна - Українська
ישראל - עברית
الإمارات العربية المتحدة - العربية
المملكة العربية السعودية - العربية
مصر - العربية
भारत - हिंदी
ไทย - ไทย
中国 - 简体中文
台灣 - 繁體中文
日本 - 日本語
香港特別行政區 - 繁體中文
대한민국 - 한국어
Algérie - Français
Estados Unidos - Español
Perú - Español
Việt Nam - Tiếng việt
Argentina - Español
France - Français
Philippines - English
Ísland - Íslenska
Australia - English
Guatemala - Español
Polska - Polski
Österreich - Deutsch
Belgique - Français
Hong Kong SAR - English
Portugal - Português
Česká Republika - Čeština
België - Nederlands
Hrvatska - Hrvatski
Puerto Rico - Español
Ελλάδα - Ελληνικά
Bolivia - Español
India - English
România - Română
България - Български
Bosna i Hercegovina - Hrvatski
Indonesia (Bahasa) - Bahasa
Schweiz - Deutsch
Казахстан - Русский
Brasil - Português
Ireland - English
Singapore - English
Россия - Русский
Canada - English
Italia - Italiano
Slovenija - Slovenščina
Україна - Українська
Canada - Français
Latvija - Latviešu
Slovensko - Slovenčina
ישראל - עברית
Chile - Español
Lietuva - Lietuvių
South Africa - English
الإمارات العربية المتحدة - العربية
Colombia - Español
Luxembourg - Français
Srbija - Srpski
المملكة العربية السعودية - العربية
Costa Rica - Español
Magyarország - Magyar
Suisse - Français
مصر - العربية
Crna Gora - Srpski
Malaysia - English
Suomi - Suomi
भारत - हिंदी
Danmark - Dansk
Maroc - Français
Sverige - Svenska
ไทย - ไทย
Deutschland - Deutsch
México - Español
Tunisie - Français
中国 - 简体中文
Dominican Republic - Español
Nederland - Nederlands
Türkiye - Türkçe
台灣 - 繁體中文
Ecuador - Español
New Zealand - English
United Kingdom - English
日本 - 日本語
Eesti - Eesti
Norge - Bokmål
United States - English
香港特別行政區 - 繁體中文
El Salvador - Español
Panamá - Español
Uruguay - Español
대한민국 - 한국어
España - Español
Paraguay - Español
Venezuela - Español
  • English (United States)‎
  • Terms of use
  • Privacy & cookies
  • Trademarks
  • © 2017 Microsoft