"Stop 0x0000006b" or Setup stops responding at "Setup is starting Windows" when you install a Windows XP SP1 client image from a Windows 2000-based RIS server

Symptoms

If you try to install a Microsoft Windows Server 2003 image, or a Microsoft Windows XP client image with slipstreamed Windows XP Service Pack 1 (SP1) or Windows XP Service Pack 2 (SP2) from a Remote Installation Services (RIS) server, Setup stops responding at the "Setup is Starting Windows" message. Or, you may receive the following Stop error message on a blue screen:
STOP: 0x0000006b (0xC000020A, 0x00000002, 0x0000000, 0x00000000) PROCESS1_INITIALIZATION_FAILED
Note The four parameters that are inside the parentheses can vary according to the configuration of the computer.


You experience this problem if the following conditions are true:
  • You are using a Windows Server 2003-based RIS server.
  • The domain controller to which your RIS server connects is running a version of Microsoft Windows 2000 Server.

Cause

This problem occurs because the Windows 2000-based domain controller does not support the Server Message Block (SMB) signing that is used by the Windows Server 2003-based RIS server. Therefore, you receive an error message when the RIS server tries to connect to the Windows 2000-based domain controller to authenticate on behalf of the RIS client.

Note Windows Server 2003, Windows XP SP1 and Windows XP SP2 use NTLM version 2 (NTLMv2) during the client-logon phase of the RIS installation.

Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to obtain the latest Windows 2000 service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.


Prerequisites

You must have Windows 2000 service pack 2 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date Time Version Size File name
----------------------------------------------------------
26-Aug-2002 17:52 5.0.2195.5781 123,664 Adsldp.dll
26-Aug-2002 17:52 5.0.2195.5781 131,344 Adsldpc.dll
26-Aug-2002 17:52 5.0.2195.5781 62,736 Adsmsext.dll
26-Aug-2002 17:52 5.0.2195.5992 358,160 Advapi32.dll
26-Aug-2002 17:52 5.0.2195.5265 42,256 Basesrv.dll
26-Aug-2002 17:52 5.0.2195.5855 49,424 Browser.dll
26-Aug-2002 17:52 5.0.2195.6012 135,952 Dnsapi.dll
26-Aug-2002 17:52 5.0.2195.6012 96,016 Dnsrslvr.dll
26-Aug-2002 17:52 5.0.2195.5722 45,328 Eventlog.dll
26-Aug-2002 17:52 5.0.2195.5907 222,992 Gdi32.dll
26-Aug-2002 17:52 5.0.2195.5859 145,680 Kdcsvc.dll
04-Jun-2002 14:31 5.0.2195.5859 199,952 Kerberos.dll
26-Aug-2002 17:52 5.0.2195.6011 708,880 Kernel32.dll
21-Aug-2002 09:27 5.0.2195.6023 71,248 Ksecdd.sys
22-Jul-2002 16:54 5.0.2195.5960 507,152 Lsasrv.dll
22-Jul-2002 16:54 5.0.2195.5960 33,552 Lsass.exe
26-Aug-2002 17:52 5.0.2195.4733 332,560 Msgina.dll
12-Aug-2002 17:54 5.0.2195.6006 108,816 Msv1_0.dll
26-Aug-2002 17:52 5.0.2195.5979 307,472 Netapi32.dll
26-Aug-2002 17:52 5.0.2195.5966 360,720 Netlogon.dll
26-Aug-2002 17:52 5.0.2195.5979 916,752 Ntdsa.dll
26-Aug-2002 17:52 5.0.2195.6025 389,392 Samsrv.dll
26-Aug-2002 17:52 5.0.2195.5951 129,296 Scecli.dll
26-Aug-2002 17:52 5.0.2195.5951 302,864 Scesrv.dll
26-Aug-2002 17:52 5.0.2195.6000 379,664 User32.dll
26-Aug-2002 17:52 5.0.2195.5968 369,936 Userenv.dll
26-Aug-2002 17:52 5.0.2195.5859 48,912 W32time.dll
04-Jun-2002 14:32 5.0.2195.5859 57,104 W32tm.exe
24-Aug-2002 11:50 5.0.2195.6028 1,642,416 Win32k.sys
15-Aug-2002 08:30 5.0.2195.6013 179,472 Winlogon.exe
26-Aug-2002 17:52 5.0.2195.5935 243,472 Winsrv.dll
26-Aug-2002 17:52 5.0.2195.5944 125,712 Wldap32.dll
Note Apply this hotfix on Windows 2000-based domain controllers, not the RIS servers. You must apply the hotfix on each Windows 2000-based domain controller in the domain to make sure that the error message does not occur again.


Important If the computer is in a child domain with a parent domain above it, and the parent domain has not been updated, the fix that is described in this article does not work in the child domain.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

More Information

The problem does not occur if you try to install Windows Server 2003-based RIS clients, Windows XP SP1-based RIS clients, or Windows XP SP2-based RIS clients in the following scenario:
  • You are using a Windows Server 2003-based RIS server.
  • The domain controller that your RIS server connects to is running a version of Windows Server 2003.
Even with the hotfix installed, the following components do not work correctly with NTLMv2-only authentication.

Note NTLMv2-only authentication is enabled by setting the LMCompatibilityLevel value to 5.
  • Windows 2000-based RIS servers.
  • Windows XP original release version-based RIS clients, Windows 2000-based RIS clients, or Microsoft Windows NT-based RIS clients.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:

285901 Remote access, VPN, and RIS clients cannot establish sessions with a server that is configured to accept only NTLM version 2 authentication

Properties

Article ID: 327536 - Last Review: Jun 2, 2009 - Revision: 1

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