"The user has not been assigned any License" alert appears when using Server-Side Synchronization

Applies to: Dynamics CRM

Symptom


After you click the Test & Enable Mailbox button on a mailbox record in Dynamics 365 (online), you encounter the following alert:

"An internal Microsoft Dynamics 365 error occurred while synchronizing appointments, contacts, and tasks for the mailbox <Mailbox Name>. The owner of the associated email server profile <Email Server Profile Name> has been notified. The system will try again later.

Email Server Error Code: Crm.8004d24b.The user has not been assigned any License"

Cause


The user does not have a Dynamics 365 license assigned in Office 365. 

Resolution


Assign a Dynamics 365 license to the user. 

NOTE:  After assigning a Dynamics 365 license to the user in the Microsoft Online Portal, it may take a few minutes for the license information to sync to Dynamics 365.

For step by step instruction for how to assign a Dynamics 365 license to a user, refer to the following article:

Purchase and assign Dynamics 365 (online) licenses