Security Only update for the .NET Framework 3.5.1, 4.5.2, 4.6, 4.6.1, and 4.6.2 updates for Windows 7 Service Pack 1 and Windows Server 2008 R2 Service Pack 1: April 11, 2017

Applies to: .NET Framework 4.6

Note


Known issues in this security update

Summary


This update resolves a vulnerability in the Microsoft .NET Framework that could allow remote code execution when the .NET Framework fails to properly validate input before loading libraries. An attacker who successfully exploits this vulnerability could take control of an affected system. The attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. Users whose accounts are configured to have fewer user rights on the system could be less impacted than users who operate with administrative user rights. To learn more about this vulnerability, see Microsoft Common Vulnerabilities and Exposures CVE-2017-0160.

Additional information about this security update


The following articles contain additional information about this security update as it relates to individual product versions. The articles may contain known-issue information.
 
  • 4014573 Description of the security update for the .NET Framework 3.5.1 for Windows 7 Service Pack 1 and Windows Server 2008 R2 Service Pack 1: April 11, 2017
  • 4014566 Description of the security update for the .NET Framework 4.5.2 for Windows Vista Service Pack 2, Windows Server 2008 Service Pack 2, Windows 7 Service Pack 1, and Windows Server 2008 R2 Service Pack 1: April 11, 2017
  • 4014558 Description of the security update for the .NET Framework 4.6 for Windows Vista Service Pack 2, Windows Server 2008 Service Pack 2, Windows 7 Service Pack 1, and Windows Server 2008 R2 Service Pack 1 and 4.6 and 4.6.1 for Windows 7 Service Pack 1, and Windows Server 2008 R2 Service Pack 1: April 11, 2017
  • 4014552 Description of the security update for the .NET Framework 4.6.2 for Windows 7 Service Pack 1 and Windows Server 2008 R2 Service Pack 1: April 11, 2017

How to obtain help and support for this security update


Applies to


This article applies to the following:

  • Microsoft .NET Framework 3.5.1, 4.5.2, 4.6, 4.6.1, and 4.6.2 when used with:
    • Windows Server 2008 R2 Service Pack 1
    • Windows 7 Service Pack 1