FIX: SyncDelivery logging folders and files are created in wrong location in Exchange Server 2016

Applies to: Exchange Server 2016 Enterprise EditionExchange Server 2016 Standard Edition

Symptoms


In a Microsoft Exchange Server 2016 environment, you may find two SyncDelivery logging folders that are created incorrectly under C:\Mailbox\SyncDelivery\Error and C:\Mailbox\SyncDelivery\Request. Additionally, logging files are written into these folders.

Typically, the folder paths should be created in the following locations:

  • C:\Program Files\Microsoft\Exchange Server\v15\TransportRoles\Logs\Mailbox\SyncDelivery\Error

  • C:\Program Files\Microsoft\Exchange Server\v15\TransportRoles\Logs\Mailbox\SyncDelivery\Request

Cause


This issue occurs because log path calculations are not handled correctly.

Resolution


To resolve this issue, install Cumulative Update 5 for Exchange Server 2016 or a later cumulative update for Exchange Server 2016.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References


Learn about the terminology that Microsoft uses to describe software updates.