Enables “VoicemailOnBusy” ActionType to be set for Exchange Online users in Skype for Business Server 2015 Busy Options

Skype for Business Server 2015

Symptoms


Consider the following scenario:

  • You have enabled Busy Options feature in a Microsoft Skype for Business Server 2015 environment that has Cumulative Update 2 (Version 6.0.9319.235) or later versions installed.
  • You enable a user for Microsoft Exchange Unified Messaging (UM) On-Premises.
  • You move the user's mailbox to Exchange Online.
  • You enable the user for Exchange UM Online by assigning on-premises hosted voice mail policy.

    Note The on-premises attributes for this user are now set as follows:
    • ExUmEnabled=False
    • HostedVoiceMail=True

In this scenario, you can’t set the BusyOnBusy option to an ActionType of VoicemailOnBusy for this user.

Additionally, you receive the following error message:

 

PS C:\Users\SfBadmin> Set-CsBusyOptions -Identity "Ken Myer" -ActionType VoicemailOnBusy

Set-CsBusyOptions : Voicemail is not enabled for Identity "Ken Myer".

At line:1 char:1

+ Set-CsBusyOptions "Ken Myer" -ActionType VoicemailOnBusy

+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

+ CategoryInfo : InvalidOperation: (:) [Set-CsBusyOptions], BobException

+ FullyQualifiedErrorId : Microsoft.Rtc.Management.Bob.Cmdlets.BobSetConfigurationCmdlet

Cause


This issue occurs because the VoicemailOnBusy action type was designed to support only on-premises Exchange UM deployments.

Resolution


To fix this issue, install the May 2017 cumulative update 6.0.9319.281 for Skype for Business Server 2015, core components.