Can't update enrollment when you enroll devices in the Intune Company Portal

This article fixes an issue in which you can't update enrollment when you enroll devices in Intune.

Symptom

You enroll devices in Intune, but see a notification in the Company Portal:

Update enrollment for full access to company resources

When you click on the notification, you see the message:

We can't update enrollment now. Try again later

Cause

The devices you are trying to enroll have an outdated version of the Company Portal.

Solution

Upgrade to the latest version of the Company Portal. For more information on updating the Company Portal, see the following options.

Windows 10 users

See Update the Company Portal app on your Windows device.

Apple iOS users

  1. Open the App Store.
  2. Tap your profile icon to open your Account page, and then scroll to see pending updates.
  3. Find Company Portal in the list of updates, and select Update.
  4. Enter your Apple password if prompted, or confirm with Fingerprint if it's configured.

Android users

  1. Open Play Store.
  2. Press the hamburger menu.
  3. Select My Apps & Games.
  4. In the list of updates, look for Intune Company Portal by Microsoft Corporation.
  5. Select the Update option to download and install the current version of the Intune Company Portal from the Play Store.