Users can't view the Outlook Delegates page in Microsoft 365

Original KB number:   4038583

Symptoms

Users can't view delegate permissions in Microsoft Outlook in Microsoft 365. Additionally, they receive the following error message:

The Delegates page is not available. Cannot access the Outlook folder.

Cause

Outlook can't correctly retrieve the delegate information from the local free/busy object in the mailbox. This issue may occur after the manager's or delegate's mailbox is moved to a new forest.

Resolution

To resolve this issue, set a new temporary delegate in the manager's mailbox by using Outlook Web App (OWA) to force updating of the local free/busy object. To do this, follow these steps:

  1. Sign in to the mailbox through OWA.

  2. Open the calendar.

  3. Select Share from the menu at the top.

    Screenshot of the Share button on the Outlook page.

  4. Enter a user or group, and then select Delegate from the drop-down menu.

    Screenshot of the selecting Delegate in the drop-down menu page.

  5. Select Share, and then select Done.

    Screenshot of Share page.

The manager should now be able to return to Outlook to continue management of the delegates from the client.