Can't retrieve time slot information about private calendar items as a delegate on another user's account in Exchange Server 2016

Applies to: Exchange Server 2013 EnterpriseExchange Server 2013 Standard EditionExchange Server 2016 Enterprise Edition More

Symptoms


Consider the following scenario:

  • You use the Windows or Outlook for Mac client to connect to Exchange Server 2016.
  • You are assigned as a delegate on another user's account.
  • The Delegate can see my private items option is enabled on the user's account.
  • Some calendar items are marked as "Private" on the user's account.

In this scenario, you can't retrieve correct free/busy information about the user's account. In this case, the time slot information about "Private" items is presented as Free.

Cause


This issue occurs because Exchange Web Services (EWS) calls do not return the items that are marked as Private.

Resolution


Exchange Server 2016

To resolve this issue, install Cumulative Update 9 for Exchange Server 2016 or a later cumulative update for Exchange Server 2016.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References


Learn about the terminology that Microsoft uses to describe software updates.