“You’ll need a new app to open this osf-roaming.16” message when starting Outlook 2016

Van toepassing: Outlook 2016Application Virtualization for Windows DesktopsApp-V 5.0 for Windows Desktops

Symptoms


When you try to start Microsoft Outlook 2016, you receive a "Do you want to allow this website to open an app on your computer?" message.

Do you want to allow this website to open an app on your computer?

If you select Allow, you receive a "You’ll need a new app to open this osf-roaming.16" message.

You’ll need a new app to open this osf-roaming.16

Cause


This issue occurs when the Click-to-Run version of Microsoft Office Professional Plus is installed on the system together with the App-V version of Microsoft Visio or Microsoft Project.

Resolution


To resolve this issue, deploy the Click-to-Run or MSI version of Microsoft Visio 2016 or Microsoft Project 2016.

For more information about how to deploy Visio 2016 or Project 2016, see the Microsoft Docs topic Deploying Microsoft Office 2016 by Using App-V.