An appointment is canceled or deleted unexpectedly during server-side synchronization
This article provides a solution to an issue where an appointment is canceled or deleted unexpectedly when you use server-side synchronization.
Applies to: Microsoft Dynamics 365
Original KB number: 4345686
Symptoms
When you use server-side synchronization to synchronize appointments between Microsoft Dynamics 365 and Exchange, an appointment is canceled or deleted unexpectedly.
Cause
This issue can occur if the appointment no longer meets the conditions of the user's sync filters. As mentioned in Ignore logically deleted items during synchronization, there are multiple reasons an appointment may no longer match your sync filters, such as the organizer of the appointment being changed, the sync filters being modified, or the user no longer having access to the record due to changes in security roles or sharing. By default, server-side synchronization sends a delete operation to Exchange in this scenario, which results in an appointment cancellation.
Resolution
A configurable setting was introduced to allow you to change this behavior. You can use one of the following tools to change the DistinctPhysicalAndLogicalDeletesForExchangeSync
setting to True:
Feedback
https://aka.ms/ContentUserFeedback.
Coming soon: Throughout 2024 we will be phasing out GitHub Issues as the feedback mechanism for content and replacing it with a new feedback system. For more information see:Submit and view feedback for