Azure Stack Hotfix 1.1807.1.78

Applies to: Azure Stack

Important


We recommend that you apply this hotfix as soon as possible after the Azure Stack 1807 update is installed to reduce the risk of running out of disk space or experiencing an infrastructure outage.

Symptoms


After the Azure Stack 1807 update is installed, you experience the following symptoms:

  • Storage for one of the hosts may progressively fill. This condition can eventually cause tenant downtime because of an outage of the Azure Stack infrastructure. Usage data will not be uploaded to Azure for billing. This can affect the ability of service providers to charge their customers for their services. In this situation, usage data that is generated between the time of the update and the installation of the hotfix will be lost. Usage information is not available through the local usage APIs, nor is it reported to Azure commerce to be added to the Azure bill. By installing the hotfix immediately, you can reduce how much data is lost.
  • Creating virtual machines from images that were syndicated before the installation of the Azure Stack 1807 update takes longer than usual.

Cause


These issues occur because of the following reasons:

  • Because of a SQL Server misconfiguration, transaction logs can grow larger than expected and affect system availability. Because the SQL Server database shares the host with other critical infrastructure, this can cause the portals to become unavailable.

  • In the Azure Stack 1807 update, changes were made to the location where Azure Stack stores syndicated images. These changes help reduce virtual machine deployment time. We fixed the issues that were preventing the reduction in deployment time.

Resolution


Download and installation information

To resolve these issues, download the following files. As soon as the files have been downloaded, follow the instructions on the Apply updates in Azure Stack page on the Microsoft Docs website to apply this update to Azure Stack.

Download the hotfix .exe file now.

Download the hotfix .bin file now.

Download the hotfix .xml file now.

Prerequisites

To apply this hotfix, you must have at least version 1.1807.0.76 installed.