"A parameter was specified that isn't valid" error when creating transport rule in Exchange Server 2019 and 2016

Applies to: Exchange Server 2019Exchange Server 2016

Symptoms


In Microsoft Exchange Server 2019 or Exchange Server 2016, when you try to create a transport rule on an Edge transport server by setting the Quarantine parameter as True, you receive the following error message:

A parameter was specified that isn't valid on an Edge Transport server.

Resolution


To fix this issue, install one of the following updates:
For Exchange Server 2019, install the Cumulative Update 4 for Exchange Server 2019 or a later cumulative update for Exchange Server 2019.
For Exchange Server 2016, install the Cumulative Update 15 for Exchange Server 2016 or a later cumulative update for Exchange Server 2016.

References


Learn about the terminology that Microsoft uses to describe software updates.