You Receive a "User32.dll Failed" Initialization Error Message, or the User Interface Does Not Update Correctly

Symptoms

If a program (for example, Microsoft Word) uses a Graphics Device Interface (GDI) API function that creates a brush, such as CreateSolidBrush, and if the program removes a window before it removes the brush, GDI resources may become low, and you may experience one or more of the following symptoms:
  • You receive an error message that is similar to the following:
    Service_Name - DLL initialization failure Initialization of the dynamic link library c:\windows\system32\user32.dll failed. The process is terminating abnormally.
  • The user interface may not update correctly. For example, menus do not display correctly, button text is lost, or icon images do not repaint.

Cause

This issue occurs because the operating system can leak a handle to a GDI brush object if a window is removed before the brush is removed.

For more information about how to troubleshoot this leak, see the "More Information" section of this article.

Resolution

Windows Server 2003

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
No prerequisites are required.
Restart Requirement
You must restart your computer after you apply this hotfix.
Hotfix Replacement Information
This hotfix does not replace any other hotfixes.
File Information
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
  Date         Time   Version       Size       File name 
-------------------------------------------------------
08-Dec-2003 06:11 5.2.3790.110 1,811,456 Win32k.sys

Windows 2000

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, you must have Windows 2000 Service Pack 4 (SP4) installed on your computer. For additional information about how to obtain the latest service pack, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

Restart Requirement
You must restart your computer after you apply this hotfix.
Hotfix Replacement Information
This hotfix does not replace any other hotfixes.
File Information
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date Time Version Size File name
--------------------------------------------------------------
10-Sep-2003 18:52 5.0.2195.6738 42,256 Basesrv.dll
17-Jan-2003 16:06 5.0.2195.6656 236,304 Cmd.exe
10-Sep-2003 18:52 5.0.2195.6762 222,992 Gdi32.dll
10-Sep-2003 18:52 5.0.2195.6816 711,440 Kernel32.dll
10-Sep-2003 18:52 5.0.2195.6807 333,584 Msgina.dll
10-Sep-2003 18:52 5.0.2195.6701 90,232 Rdpwd.sys
04-Sep-2003 17:06 5.0.2195.6801 5,232,128 Sp3res.dll
10-Sep-2003 18:52 5.0.2195.6799 380,176 User32.dll
10-Sep-2003 18:52 5.0.2195.6794 385,808 Userenv.dll
08-Sep-2003 17:21 5.0.2195.6817 1,628,464 Win32k.sys
03-Sep-2003 22:13 5.0.2195.6815 182,032 Winlogon.exe
10-Sep-2003 18:52 5.0.2195.6775 243,984 Winsrv.dll
10-Sep-2003 18:52 5.0.2195.6816 711,440 Kernel32.dll
08-Sep-2003 17:21 5.0.2195.6817 1,628,464 Win32k.sys
10-Sep-2003 18:52 5.0.2195.6775 243,984 Winsrv.dll

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

More Information

To troubleshoot this problem, use the Gdiobj.exe tool to monitor the Brush column for PID 0. PID 0 represents GDI objects that are not private. If the Brush column continuously increases but does not decrease, you may be experiencing the leak that is described in this article. In this case, you can see the leak when you start and stop Microsoft Word; the Brush column increases by 2, but when you exit the program, it does not decrease.

To download the Gdiobj.exe tool, visit the following Feng Yuan Web site:For addition information about GDI objects, visit the following Microsoft Web site:For additional information about how hotfix packages are named , click the following article number to view the article in the Microsoft Knowledge Base:

816915 New Naming Schema for Microsoft Windows Hotfix Packages

Properties

Article ID: 826518 - Last Review: Feb 15, 2017 - Revision: 3

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