A mail-enabled contact may receive a Winmail.dat file attachment with an SMTP e-mail message instead of receiving the correct file attachment in Exchange Server


Symptoms


When a Microsoft Exchange Server user sends a Simple Mail Transfer Protocol (SMTP) e-mail message with an attachment to a mail-enabled contact in the Global Address List, the mail-enabled contact may receive a Winmail.dat file attachment with the e-mail message instead of receiving the correct file attachment.

Cause


This issue may occur if the following conditions are true for the mail-enabled object on the Exchange computer:
  • The default message format is set to Rich Text Format (RTF).
  • The mAPIRecipient attribute is missing, is set to null, or is set to true.

    Note This typically occurs if the mail-enabled contact is added by using a script.

Resolution


To resolve this issue, change the settings in Active Directory Users and Computers so that the mail-enabled contact does not use RTF as the default message format. To do this, follow these steps:
  1. Open Active Directory Users and Computers. To do this, click Start, point to Programs, point to Administrative Tools, and then click Active Directory Users and Computers.
  2. Click the container where the mail-enabled contact is located.
  3. Right-click the mail-enabled contact in the right-pane, and then click Properties.
  4. Click the Exchange Advanced tab, and then click to clear the Use MAPI rich text format check box.
  5. Click Apply, and then click OK.