When you use Outlook to connect to your Exchange server mailbox by using RPC over HTTP, you receive messages that continuously prompt you for your network password

Applies to: Microsoft Office Outlook 2003Microsoft Office Outlook 2007

Symptoms


When you use Microsoft Office Outlook 2007 or Microsoft Office Outlook 2003 to connect to your Exchange server mailbox by using a remote procedure call (RPC) over HTTP, you receive messages that continuously prompt you for your network password.

Cause


This issue occurs when one of the following conditions is true:
  • Your password has expired.
  • Your administrator has set the User must change password at next logon option for your user account.

Resolution


Change your network password by using any one of the following methods that are available in your environment:
 
  • Log on through a VPN connection to the network.
  • Log on to the Local Area Network (LAN).
  • Use the Internet Information Server (IIS) Change Password feature with Outlook Web Access (OWA). For information about how to configure the IIS Change Password feature, see the following article from the Microsoft Knowledge Base
For additional information on changing your password via OWA, click the following article number to view the article in the Microsoft Knowledge Base:

297121 Using the Change Password feature with Outlook Web Access

Status


Microsoft has confirmed that this is a problem in Outlook 2003.
Microsoft has confirmed that this is a problem in Outlook 2007.
When you connect with RPC over HTTP, Outlook does not receive a distinguishable error code from the IIS server when a logon fails.  Some reasons for the failure include an expired password, an incorrect password, or an account lockout. However, Outlook frequently only recognizes that the logon failed.  Therefore, you continuously receive messages that prompt you for your password.

Additionally, Microsoft Windows provides no secure, programmatic way for password changes for Outlook clients that are outside the network.