"Crystal Print Engine Error: Failed to open a rowset" error when you try to print a report in Microsoft Dynamics SL

This article provides solutions to errors that occur when you try to print a report in Microsoft Dynamics SL.

Applies to:   Microsoft Dynamics SL
Original KB number:   905310

Symptoms

When you try to print a report in Microsoft Dynamics SL or in Microsoft Business Solutions - Solomon, you receive an error message that is similar to the following example:

Crystal Reports Helper Application for Solomon IV

Cannot start print job.

Report: Drive :\Program Files\Solomon\Module_Code\XXXXX.RPT Crystal Print Engine Error: 723 - Error in File Drive :\Program Files\Solomon\Module_Code\XXXXX.RPT:

Failed to open a rowset.

Note

In this error message, Drive represents the drive on which you installed Microsoft Dynamics SL, Module_Code represents the module code that corresponds to the Microsoft Dynamics SL module in which the report is located, and XXXXX represents the file name of the report.

Cause

This problem occurs for one or more of the following reasons.

Cause 1

The report contains notes. See Resolution 1.

Cause 2

You have Microsoft Solomon 6.0 installed, and the report that causes the error is the Account Distribution (01.ACC.DI) report. See Resolution 2.

Cause 3

The report is a custom report that uses a preprocess. See Resolution 3.

Cause 4

The Open DataBase Connectivity (ODBC) Data Source Names (DSNs) are missing or corrupted. See Resolution 4.

Cause 5

The option to use ANSI quoted identifiers isn't selected. See Resolution 5.

Cause 6

There isn't enough free disk space on the computer that is running Microsoft SQL Server, and hosts the Microsoft Dynamics SL databases or the Microsoft Business Solutions - Solomon databases. See Resolution 6.

Resolution

To resolve this problem, use the appropriate resolution.

Resolution 1

If you receive the error message when you try to print a report that contains notes, click to clear the Select Distinct Records check box on the Database menu in Crystal Reports for Solomon.

Resolution 2

If you receive the error message only when you try to print the Account Distribution (01.ACC.DI) report, and have Microsoft Solomon 6.0 installed, replace the 01acctdi.rpt file that is in your installation by using the 01acctdi.rpt file from the Microsoft Solomon 5.5 installation CD.

Resolution 3

If you receive the error message when you try to print a custom report that uses a preprocess, use one of the following methods.

Method 1

Add the custom report as a separate item in the Microsoft Dynamics SL menu structure.

Method 2

Attach the custom report as a new report format to an existing report that doesn't use a preprocess. To attach the custom report, follow these steps:

  1. Start Microsoft Dynamics SL.

  2. On the Utility menu, select Report Control Maintenance.

    Note

    The Report Control Maintenance (98.300.00) dialog box opens.

  3. In the Report Number box, enter the number of the report to which you want to attach the custom report.

  4. Select Control Options.

  5. Verify that the Pre-Process box is blank. If the Pre-Process box isn't blank, go back to step 3, and then enter a different report number.

  6. On the first blank row, type the display name of the report in the Report Format Name box, and then type the report file name in the Report Format box.

    In this step, "the report" refers to the Crystal Reports report in Microsoft Windows. For example, type 01accdi in the Report Format box if the report file name is 01accdi.rpt.

  7. Select Save. Then select Close.

Resolution 4

Remove and then re-create the Microsoft Dynamics SL or Microsoft Solomon database ODBC DSNs. To do it, follow these steps:

  1. Select Start, select Control Panel, select Administrative Tools, and then select Data Sources (ODBC).
  2. On the User DSN tab, select a Dynamics SL database, and then select Remove. Repeat for all Dynamics SL databases that appear in the list.
  3. On the System DSN tab, select a system data source that relates to a Dynamics SL database, and then select Remove.
  4. Select OK.
  5. To re-create the ODBC DSNs, start Microsoft Dynamics SL, and then run a print preview of any report.

Resolution 5

Turn on ANSI (American National Standards Institute) quoted identifiers. To do it, follow these steps:

  1. Select Start, select Control Panel, select Administrative Tools, and then select Data Sources (ODBC).
  2. On the User DSN tab, select the appropriate database, and then select Configure.
  3. Select Next.
  4. Specify the appropriate credentials, and then select Next.
  5. Select the Use ANSI quoted identifiers check box.
  6. Select Next.
  7. Select Finish.
  8. Select OK two times.

Resolution 6

Free some disk space on the computer. To do it, delete unnecessary data or increase the disk capacity.