FIX: Add-ins, smart documents, or smart tags that you create by using Microsoft Visual Studio 2005 do not run in Office

Symptoms

When you use Microsoft Visual Studio 2005 to create add-ins, smart documents, or smart tags, you may experience the following symptoms:
  • The add-ins, the smart documents, or the smart tags cannot be loaded in any Microsoft Office application.
  • The add-ins, the smart documents, or the smart tags do not run in any version of Microsoft Office.
This problem occurs when you create the add-ins, the smart documents, or the smart tags on a computer that has the Microsoft .NET Framework 2.0 installed.

Note This problem does not occur when you log on by using a Microsoft Windows user account that has restricted permission.

Resolution

The update for Visual Studio 2005 that is described in this article lets you redistribute the required fixes in Office and the .NET Framework together with the solutions that you write in Visual Studio 2005. This update adds a new Shared Add-in Support Update for the Microsoft .NET Framework 2.0 (KB908002) option to the Visual Studio 2005 prerequisites list. When you create a Setup project of a managed add-in, smart document, or smart tag, you must enable this option in the Setup project that will include the required redistributable updates to Office and to the .NET Framework.

To resolve this problem for Visual Studio 2005 developers, a redistributable version of the update for Visual Studio 2005 is available.

The following file is available for download from the Microsoft Download Center:
Download Download the VS2005-KB908002-ENU-x86.EXE package now.

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.


To install this update for Visual Studio 2005, we recommend that you follow these steps:
  1. Save the download package on your computer.
  2. Double-click the download package to run the package.
  3. Read and then accept the Microsoft Software License Terms.
After you install this update, you must include the Shared Add-in Support Update for the Microsoft .NET Framework 2.0 (KB908002) option among the prerequisites in the solution Setup project whenever you create a shared add-in project in Visual Studio 2005. To do this, follow these steps:

  1. In Solution Explorer, right-click the solution Setup project, and then click Properties.
  2. Click Prerequisites.
  3. Click to select the Shared Add-in Support Update for the Microsoft .NET Framework 2.0 (KB908002) check box.
Note You must enable this prerequisite separately for both Debug and Release builds.

Note This update is installed on a per-user basis. Therefore, install the update for each user account that requires the update.

Whenever you build your Setup project, Visual Studio 2005 will include the redistributable updates with your project in a folder that is named KB908002. This folder is located in the application Setup folder. The contents of the KB908002 folder are required for the solution Setup logic to work correctly. The Setup.exe file that Visual Studio 2005 builds with the Setup project will apply the updates to the destination computer when the solution is installed.

Note The .NET Framework 2.0 and Microsoft Windows Installer 2.0 are required for the fixes to be installed correctly on the destination computer.

Note This .msi file has no ALLUSERS specification. Therefore, when you install this .msi file, the file is installed in the user context per-user instead of per-machine.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

Steps to reproduce the problem

  1. Start Microsoft Visual Studio 2005.
  2. Create a shared add-in. To do this, follow these steps:
    1. On the File menu, click
      New, and then click Project.
    2. In the New Project dialog box, click
      Other Project Types, and then click
      Extensibility.
    3. Click Shared Add-in, type a name in the Name box, and then click OK.
    4. Follow the instructions in the Shared Add-in wizard to create a Microsoft Word add-in.
  3. Build the project. To do this, follow these steps:
    1. On the Project menu, click
      YourProjectNameProperties.
    2. On the
      YourProjectName tab, click
      Build, and then click Release in the
      Configuration list.
    3. On the Build menu, click Build Solution.
  4. On the File menu, click
    Exit to exit Visual Studio.
  5. Deploy the add-in. To do this, follow these steps:
    1. Click Start, and then click My Documents.
    2. Open the following folder:
      Visual Studio 2005\Projects\YourProjectName\YourProjectNameSetup\Debug
      By default, the project that you built in step 3 is saved to the Visual Studio 2005 folder.
    3. Copy the following files to the desktop on a second computer:
      • Setup.exe
      • YourProjectNameSetup.msi
    4. Double-click the Setup.exe file, and then accept all the default settings.
  6. Start Microsoft Word.
  7. On the Tools menu, click Templates and Add-Ins.
  8. Click Add. You receive an error message in a COM Add-Ins dialog box.

References

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

907417 Description of the update for Office 2003: November 8, 2005

Note The update that is described in Microsoft Knowledge Base article 907417 lets end-users of Office 2003 fix only the Otkloadr.dll issue. The article does not address the Extensibility.dll issue or versions of Office that differ from Office 2003.

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

908003 FIX: Office 2003 crashes when you try to close a Word document or an Excel spreadsheet from a WinForm control in a Visual Studio Tools for the Office System version 2003 solution

908004 FIX: You cannot run a customization that was created in Microsoft Visual Studio Tools for the Microsoft Office System version 2003

Properties

Article ID: 908002 - Last Review: Mar 23, 2009 - Revision: 1

Feedback