You receive a "You must provide a value for Decimals Supported" message when you try to save changes to a product that was imported into Microsoft CRM by using the Microsoft CRM Assessment Import program


Symptoms


When you try to save changes to a product that was imported into Microsoft CRM 3.0 by using the Microsoft CRM Assessment Import program, you receive the following message:
You must provide a value for Decimals Supported

Cause


This problem occurs if the Decimals Supported field is not set to a value. If this field does not contain a value, you may not be able to correctly save products that are added to opportunities, quotes, orders and invoices.

Resolution


To resolve this issue, specify a value for the Decimals Supported field. This value must be between 0 and 4. To do this, follow these steps:
  1. Log on to Microsoft CRM.
  2. Click Settings, click Product Catalog, and then click Products.
  3. Open the product that was imported by using the Microsoft CRM Assessment Import program.
  4. Specify a value for the Decimals Supported field.
  5. Save the product record.