ActiveSync does not recognize a Windows Mobile 5.0 device attached by USB cable or cradle


Microsoft Activesync 4.5 is now available. If your device is running Windows Mobile 5.0 software or later versions and syncs with computers that are running Windows XP, you should upgrade to Activesync 4.5. In some cases, issues in this document will be resolved by upgrading to Activesync 4.5. However, the content of this troubleshooting guide also applies to Activesync 4.5 in many cases. It is recommended that you reference this guide for issues you experience with Activesync 4.5 as well.


View the following Microsoft Web site to download Activesync 4.5:http://www.microsoft.com/windowsmobile/en-us/downloads/microsoft/activesync-download.mspx

Symptoms


The Microsoft Windows Mobile device is not recognized when you attach it to your computer using a USB cable or cradle.

Cause


This problem occurs when a firewall application blocks ActiveSync application processes. Firewall applications are designed to help block network traffic and help secure the personal computer from incoming network connections. Because ActiveSync uses TCP ports for data transfer with Windows Mobile-based devices, you may have to unblock this traffic in the firewall application. You must add the ActiveSync application processes to the firewall application exception list.

Sometimes, when you add ActiveSync 4.1 or ActiveSync 4.0 to the firewall application exception list, the firewall application will not let the communication between ActiveSync and the Windows Mobile 5.0 device succeed. This behavior occurs in the following cases and may occur in other cases:
  • Firewall-hook drivers prevent successful synchronized communications. When you use Microsoft Windows XP, contact the firewall vendor to verify that you are using the version of the firewall that works best with Windows XP.
  • You use a firewall that implements its own TCP/IP stack. Certain firewalls can implement all Windows TCP/IP interfaces and APIs. These firewalls can also mimic the TCP/IP stack in Windows XP. In this case, the TCP/IP stack of the firewall may not handle the synchronized communication and the Windows TCP/IP stack. This behavior causes problems or communication failures between the Windows Mobile 5.0-based device and ActiveSync.

Resolution


To resolve this problem, contact the firewall vendor to determine whether one of the following conditions is true:
  • The firewall is designed as a firewall-hook driver.
  • The firewall uses the firewall that is included with Windows XP Service Pack 2 (SP2).
For more information about firewall troubleshooting steps, visit the following Microsoft Web site:

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


We do not recommend that firewall vendors implement their firewalls as a firewall-hook driver. Additionally, we do not recommend that firewall vendors implement their firewalls as a firewall driver for Windows XP and for later versions of the operating system.

The Microsoft Windows 2000 Driver Development Kit (DDK) introduced the concept of a firewall-hook driver. A firewall-hook driver was intended to manage network packets that were sent and received across a firewall in the context of the TCP/IP protocol.

A firewall-hook driver did not meet the firewall requirements because the driver ran too high in the network stack. A firewall-hook driver could also interfere with the operation of Internet Connection Sharing or a personal firewall.

To provide firewall functionality in Windows XP and in later versions of the operating system, firewall vendors should create a network driver interface specification (NDIS) intermediate miniport driver to manage packets that are sent and received across a firewall.

For more information, visit the following Microsoft Developer Network (MSDN) Web sites:

References


Forums Visit our Windows Phone Forums for more helpful hints and ideas.