How to add the due date information in the RM Statement on Blank Paper report for customers who belong to a National Account in Microsoft Dynamics GP 9.0, in Microsoft Great Plains 8.0, and in Microsoft Great Plains 7.5


INTRODUCTION


This article describes how to add the due date information for customers who belong to a National Account in the RM Statement on Blank Paper report in Microsoft Dynamics GP 9.0, in Microsoft Business Solutions - Great Plains 8.0, and in Microsoft Great Plains 7.5.

MORE INFORMATION


1. Start Report Writer. To do this, follow these steps:
a. On the Tools menu, point to Customize , and then click Report Writer .
b. If you are using Microsoft Dynamics GP 9.0, click Microsoft Dynamics GP in the Product list, and then click OK . If you are using Microsoft Great Plains 8.0 or Microsoft Great Plains 7.5, click Great Plains in the Product list, and then click OK .
2. In Report Writer, click Reports .
3. In the Original Reports list, click RM Statement On Blank Paper , and then click Insert .
4. Create a table relationship. To do this, follow these steps:
a. On the toolbar, click Tables , and then click Tables .
b. In the Tables dialog box, click RM_Statements_TRX_TEMP , and then click Open .
c. In the Table Definition dialog box, click Relationships .
d. In the Table Relationship dialog box, click New .
e. Click the ellipsis button ( ... ) to the right of the Secondary Table field.
f. In the Relationship Table Lookup dialog box, click RM Open File , and then click OK .
g. In the Secondary Table Key list, click RM_Open_Key4 .
h. In the first Primary Table list, click RM Document Type-All .
i. In the second Primary Table list, click Document Number , and then click OK .
j. Close the Table Relationship dialog box.
k. Click OK .
l. Close the Tables dialog box.
5. Create a report relationship. To do this, follow these steps:
a. In the Modified Reports list, click RM Statement On Blank Paper , and then click Open .
b. In the Report Definition dialog box, click Tables .
c. In the Report Table Relationships dialog box, click 05.-RM Statement Transaction Temporary File , and then click New .
d. In the Related Tables dialog box, click RM Open File , and then click OK .
e. Click Close .
6. Add the Due Date field to the layout. To do this, follow these steps:
a. In the Report Definition dialog box, click Layout .
b. In the Toolbox dialog box, click RM Open File in the table list.
c. Drag the Due Date field to the B section of the report.
d. Close the report layout.
e. When you receive the following message, click Save :

Do you want to save the changes to this report layout?

7. Save the report, and then close Report Writer. To do this, follow these steps:
a. In the Report Definition dialog box, click OK .
b. On the File menu, click Microsoft Business Solutions - Great Plains .

Note In Microsoft Dynamics GP 9.0, click Microsoft Dynamics GP on the File menu.
8. Grant access to the report.

Method 1: Use Advanced Security
a. On the Tools menu, point to Setup , point to System , and then click Advanced Security . Type the system password if you are prompted to do this.
b. Click View , and then click by Alternate, Modified and Custom .
c. Expand the following nodes: • Great Plains

Note In Microsoft Dynamics GP 9.0, expand Microsoft Dynamics GP .
Reports
Sales
RM Statement on Blank Paper


     
d. Click Great Plains (Modified) .

Note In Microsoft Dynamics GP 9.0, click Microsoft Dynamics GP (Modified) .
e. Click Apply , and then click OK .

Note By default, when you start the Advanced Security tool, the current user and the current company are selected. Any changes that you make are made for the current user and for the current company. However, you can select additional users and companies in the following areas of the Advanced Security window: • Company
User


     
Method 2: Use standard security
a. On the Tools menu, point to Setup , point to System , and then click Security . Type the system password if you are prompted to do this.
b. In the User ID list, click the user ID of the user to whom you want to give access to the report.
c. In the Type list, click Modified Reports .
d. In the Series list, click Sales .
e. In the Access List box, double-click RM Statement On Blank Paper , and then click OK . An asterisk appears next to the report name.