You cannot create a new MAPI or messaging profile in Outlook 2003 after you remove Outlook 2007 from the computer


Symptoms


Consider the following scenario. You install and then remove Microsoft Office Outlook 2007 on the computer. Then, you install Microsoft Office Outlook 2003. However, when you try to create a new MAPI or messaging profile in Outlook 2003, the operation is not completed successfully. You cannot create a new MAPI or messaging profile.

Cause


This issue occurs if the following conditions are true:
  • Outlook 2007 is installed on a new computer and then is later uninstalled.
  • Another program that is installed creates a mapisvc.inf file.
  • The date stamp of the mapisvc.inf file that the other program installed is more recent than the date stamp of the mapisvc.inf file that Outlook 2003 tries to install.
The Setup program for Outlook 2007 does not install the Mapisvc.inf file on the computer. Therefore, when you remove Outlook 2007, the Setup program for Outlook 2007 does not also remove the Mapisvc.inf file. Additionally, the Setup program for Outlook 2003 does not overwrite the Mapsvc.inf file if the one that exists on the computer has a more recent date stamp.

Workaround


To work around this issue, follow these steps.

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Delete the Mapisvc.inf file. To do this, follow these steps:
    1. Click Start, and then click
      Search.
    2. In the All or part of the file name box, type Mapisvc.inf, and then click
      Search.
    3. In the search results list, right-click
      Mapisvc.inf, and then click
      Delete.
    4. Click Yes when you are prompted to confirm the deletion.
  2. Use the Add or Remove Programs feature to repair the installation of Outlook 2003. To do this, follow these steps:
    1. Click Start, click
      Run, type appwiz.cpl in the
      Open box, and then click OK.
    2. In the list of currently installed programs, click the entry for Outlook 2003, and then click Change.
    3. Click Reinstall or Repair, and then click Next.
    4. Follow the instructions to repair the installation of Outlook 2003.