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Symptoms

A Windows Server 2003-based computer stops responding when you shut down the computer in a remote console session. This problem occurs randomly.

Note You may establish a remote console session by using the Remote Desktop Connection tool (Mstsc.exe) together with the /console switch.

Cause

In a regular Windows Server 2003 shutdown process, the operating system has a time-out period during which the service control manager (SCM) shuts down services. If the SCM does not finish shutting down all the services within the time-out period, the operating system continues to shut down without waiting. The time-out period is specified in the WaitToKillServiceTimeout registry entry. The default time-out period lasts 20 seconds.

However, if you shut down a computer in a remote console session, the operating system continues to shut down regardless of the time-out period. In this case, the operating system continues to shut down several seconds after the SCM sends a shutdown notification to the service. Then, the NTFS driver begins to shut down as part of the system shutdown process. The NTFS driver begins to shut down earlier than expected when the service is still shutting down. The service may access disk resources during the shutdown process. A deadlock is likely to occur between the NTFS shutdown operation and the disk resource access.

Resolution

Important This hotfix supersedes an older hotfix that was released with the same Microsoft Knowledge Base article number (930045). If you have already applied the old hotfix, you must remove the old hotfix and then install the current hotfix. To remove the old hotfix, use the Add or Remove Programs item in Control Panel.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003 with Service Pack 1, x86-based versions

File name

File version

File size

Date

Time

Platform

Termsrv.dll

5.2.3790.3043

246,272

14-Nov-2007

09:19

x86

Windows Server 2003 with Service Pack 2, x86-based versions

File name

File version

File size

Date

Time

Platform

Termsrv.dll

5.2.3790.4188

246,272

14-Nov-2007

09:15

x86

Windows Server 2003 with Service Pack 1, Itanium-based versions

File name

File version

File size

Date

Time

Platform

Termsrv.dll

5.2.3790.3043

698,368

14-Nov-2007

07:08

IA-64

Windows Server 2003 with Service Pack 2, Itanium-based versions

File name

File version

File size

Date

Time

Platform

Termsrv.dll

5.2.3790.4188

698,880

14-Nov-2007

07:12

IA-64

Windows Server 2003, x64-based versions

File name

File version

File size

Date

Time

Platform

Termsrv.dll

5.2.3790.3043

365,056

14-Nov-2007

07:08

x64

Windows Server 2003 with Service Pack 2, x64-based versions

File name

File version

File size

Date

Time

Platform

Termsrv.dll

5.2.3790.4188

365,056

14-Nov-2007

07:14

x64

Workaround

To work around this problem, do not restart the Windows Server 2003-based computer in a remote console session. Or, do not shut down the Windows Server 2003-based computer in a remote console session.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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