Error message when you try to install Business Portal for Microsoft Dynamics GP 10.0: "The language is not supported on the server"


Symptoms


When you try to install Business Portal for Microsoft Dynamics GP 10.0, you receive the following error message:
Feature Id: BP Home
Location: D:\Program Files\Common Files\Microsoft Shared\Web ServerExtensions\12\TEMPLATE\FEATURES\BPHome

Action: Install
Exception: The language is not supported on the server.

Cause


This problem occurs because the Business Portal server does not have the English (United States) regional settings.

Workaround


To work around this problem, follow these steps:

For Windows 2003

  1. Exit the Business Portal installation.
  2. Click Start, point to Control Panel, and then click Regional and Language Options.
  3. On the Regional Options tab, click
    English (United States) under Standards and formats.
  4. Under Location, click United States.
  5. On the Advanced tab, click
    English (United States) under Language for non-Unicode programs, and then click OK.
  6. Install Business Portal.
Note After you install Business Portal, you can change the regional settings back to the settings that you want.

For Windows 2008

  1. Exit the Business Portal installation.
  2. Click Start, point to Control Panel, and then click Regional and Language Options.
  3. On the Format Tab, select English (United States) under the current format.
  4. On the Location Tab select United States and then click OK.
  5. Install Business Portal.


Note After you install Business Portal, you can change the regional settings back to the settings that you want.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.