Error message when you run the Dcgpofix.exe tool on a Windows Server 2008-based domain controller: "The Active Directory schema version for this domain and the version for this tool do not match"

Applies to: Windows Servers

Symptoms


When you run the Dcgpofix.exe tool on a Windows Server 2008-based domain controller, you may receive the following error message:
The Active Directory schema version for this domain, and the version supported by this tool do not match.

Cause


This problem occurs because the Dcgpofix.exe tool uses a schema check to make sure that the correct behavior occurs. The correct behavior depends on the schema version of the Active Directory schema. When the Dcgpofix.exe tool does not correctly check the schema version of the Active Directory schema, this problem occurs.

Workaround


To work around this problem, use the Dcgpofix.exe command-line tool together with the /ignoreschema parameter. To do this, run the following command at the command prompt:
dcgpofix.exe /ignoreschema

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.