Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Source: Microsoft Support

RAPID PUBLISHING

RAPID PUBLISHING ARTICLES PROVIDE INFORMATION DIRECTLY FROM WITHIN THE MICROSOFT SUPPORT ORGANIZATION. THE INFORMATION THAT IS CONTAINED HEREIN IS CREATED IN RESPONSE TO EMERGING OR UNIQUE TOPICS, OR IS INTENDED TO SUPPLEMENT OTHER KNOWLEDGE BASE INFORMATION.

Symptoms

When you access a Web part in the HRM Benefit Self Service Business Portal application in Microsoft Dynamics GP, you receive the following error message:

Server Error in ‘/’ Application. Request timed out.

Cause

This problem is related to various timeout settings of the operating environment.

Resolution

To resolve this problem, change the timeout settings. To do this, follow these steps:



Internet Information Services (IIS) connection timeout setting



For IIS 6.0:

  1. On the Web server, click Start, point to Control Panel, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.

  2. Expand the local computer node, expand Web Sites, right-click the appropriate Web site, and then click Properties.

  3. Click the Web Site tab.

  4. In the Connections area, change the value in the Connection timeout field, and then click OK.

    Note The recommended value for the Connection timeout field is 300 seconds.

For IIS 7.0:

  1. On the Web server, click Start, point to Control Panel, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.

  2. Expand the local computer node, expand Web Sites, right-click the appropriate Web site, point to Manage Web Site, click Advanced Settings.

  3. In the Advanced Settings window, expand Connection Limitschange, change the value in the Connection timeout field, and then click OK.

    Note The recommended value for the Connection timeout field is 300 seconds.



IIS Active Server Pages (ASP) setting

For IIS 6.0:

  1. On the Web server, click Start, point to Control Panel, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.

  2. Expand the local computer node, expand Web Sites, right-click the appropriate Web site, and then click Properties.

  3. Click the Home Directory tab, and then click Configuration.

  4. In the Application Configuration window, click the Options tab.

  5. Change the values in the following fields:

    • Session timeout

    • ASP script timeout

  6. Click OK.

    Note The recommend value for the Session timeout field is 20 minutes, and the recommend value for the ASP script timeout field is 1200 seconds.


For IIS 7.0:

  1. On the Web server, click Start, point to Control Panel, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.

  2. Expand the local computer node, expand Web Sites, select the appropriate web site and double-click Session State in the right hand panel.

  3. Change the setting for Time-Out. (The recommended setting is 20 minutes.)


Web.Config http execution Timeout setting

For IIS 6.0 and IIS 7.0:

  1. Right-click the Web.config file on the server where Business Portal is installed, point to Open With and then click Notepad.

    The default location of the Web.config file is C:\inetpub\wwwroot\wss\VirtualDirectories\<select your port number>

  2. Locate the following section:

    <httpRuntime maxRequestLength="51200" />
  3. Change the section in step 2 as follows:

    <httpRuntime maxRequestLength="51200" executionTimeout="300"/>
  4. On the File menu, click Save.

  5. On the File menu, click Exit.

    Note Restart the IIS services for these changes to take effect.


ASP Script Timeout Settings



For IIS 7.0:

  1. On the Web server, click Start, point to Control Panel, point to Administrative Tools, and then click Internet Information Services (IIS) Manager .

  2. Expand the local computer node, expand Web Sites, select the appropriate web site and double-click ASP in the right hand panel.

  3. In the ASP window, expand 'Limits Properties' and change the Script Timeout value. (The recommended setting is 20 minutes.)


Additional recommendations

The following list describes recommended settings. These benchmark settings may need to be adjusted based on the server configuration and environment.

Benchmark settings related to time out errors that occur when you open the Post Annual Open Enrollment page

Name

Default

Benchmark

Records

Connection timeout setting

120 seconds

300 seconds

3000

ASP timeout setting

90 seconds

90 seconds

3000

Session timeout setting

20 minutes

20 minutes

3000

Web.config httpRuntime

none

300 seconds

3000


Benchmark settings related to time out errors that occur when you post in the Post Annual Open Enrollment page

Name

Default

Benchmark

Records

Connection timeout setting

120 seconds

720 seconds

3000

ASP timeout setting

90 seconds

720 seconds

3000

Session timeout setting

20 minutes

20 minutes

3000

Web.config httpRuntime

none

720 seconds

3000

DISCLAIMER

MICROSOFT AND/OR ITS SUPPLIERS MAKE NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY, THE RELIABILITY OR THE ACCURACY OF THE INFORMATION THAT IS CONTAINED IN THE DOCUMENTS AND THE RELATED GRAPHICS PUBLISHED ON THIS WEB SITE (THE “MATERIALS”) FOR ANY PURPOSE.

THE MATERIALS MAY INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS AND MAY BE REVISED AT ANY TIME WITHOUT NOTICE. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, MICROSOFT AND/OR ITS SUPPLIERS DISCLAIM AND EXCLUDE ALL REPRESENTATIONS, WARRANTIES, AND CONDITIONS WHETHER EXPRESS, IMPLIED OR STATUTORY, INCLUDING BUT NOT LIMITED TO REPRESENTATIONS, WARRANTIES, OR CONDITIONS OF TITLE, NON-INFRINGEMENT, SATISFACTORY CONDITION OR QUALITY, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WITH RESPECT TO THE MATERIALS.

References

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×