Error message when you try to run an Integration Services package in SQL Server 2008 on an IA-64-based computer: "Error 0x3: Script Task 1: There was an exception while loading Script Task"


Symptoms


When you try to run a SQL Server Integration Services (SSIS) package in Microsoft SQL Server 2008, the Integration Services package may not run as expected. You may receive an error message that resembles the following:
Warning: Script Task 1: Found SQL Server Integration Services 2005 Script Task "ScriptTask_eec78d42403c4257ba3bd09c2352f060" that requires migration!


Error 0x3: Script Task 1: There was an exception while loading Script Task from XML: System.IO.FileNotFoundException: Could not load file or assembly 'VSTADTEProvider.Interop, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

File name: 'VSTADTEProvider.Interop, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'

at Microsoft.SqlServer.VSTAHosting.VSTAScriptingEngine.EnsureDTEObject()

at Microsoft.SqlServer.VSTAHosting.VSTAScriptingEngine.InitNewScript(String languageID, String projectname, String projectext, Boolean bCleanupOnClose)

at Microsoft.SqlServer.VSTAHosting.VSTAScriptingEngine.InitNewScript(String languageID, String projectname, String projectext)
at Microsoft.SqlServer.Dts.Tasks.ScriptTask.ScriptTask.LoadFromXML(XmlElement elemProj, IDTSInfoEvents events)

Cause


This problem can occur when the following conditions are true:
  • SQL Server 2008 is installed on an IA-64-based computer.
  • The Integration Services package was created in one of the following versions of SQL Server:
    • SQL Server 2008 Release Candidate 0
    • SQL Server 2008 Community Technology Preview 6
    • SQL Server 2005 Service Pack 2
    • SQL Server 2005 Service Pack 1
    • SQL Server 2005
  • The Integration Services package contains a script task or a script transform.

Workaround


To work around this issue, use an instance of SQL Server 2008 that is installed on an x86-based computer or an instance that is installed on an x64-based computer to upgrade the package. Then, run the package in SQL Server 2008 on the IA-64-based computer.

More Information


Integration Services packages that are created in versions of SQL Server that are earlier than the release version of SQL Server 2008 must be upgraded before the package will run in the release version of SQL Server 2008. Integration Services packages that are created in earlier versions of SQL Server 2008 are automatically upgraded and recompiled by Visual Studio Tools for Applications (VSTA). However, this VSTA functionality is not available on IA-64-based computers. Therefore, the Integration Services package is not upgraded, and it will not run as expected.