You experience issues in Outlook when you try to configure free/busy information or when you try to delegate information

Symptoms

In Microsoft Outlook, you experience one of the following issues when you try to configure free/busy information or when you try to delegate information: 

  • When you accept a meeting request or when you add a delegate to your mailbox, you receive the following error message:
    Unable to save free/busy information
  • When you use the outlook.exe /cleanfreebusy command-line switch to start Outlook, you receive the following error message:
    Unable to clean your local free/busy information.
  • When you try to add a delegate, you receive one of the following error messages:
    The Delegates settings were not saved correctly. Unable to activate free/busy information.
    The Delegates settings were not saved correctly. Unable to activate send-on-behalf-of list. You do not have sufficient permission to perform this operation on this object.
  • When you try to open a shared calendar item, you receive the following error message:
    Can't open this item. Unable to open the free/busy information
    Additionally, the following event is logged in the Application log on the Outlook client computer:
  • When a delegate tries to create an item in the shared calendar or in the manager calendar, the delegate receives the following error message:
    Unable to open free/busy information
  • You receive the following error message when trying to add a delegate in Outlook:
    The delegate settings were not saved correctly. Could not activate free/busy information.

  • You receive the following error message when you try to add a delegate in Outlook:
    The delegate settings were not saved correctly. Could not activate free/busy information.


Cause

These issues occur because a mailbox property does not correctly reference a hidden message in the mailbox. The hidden message contains information that is related to any of the following features:

  • free/busy publishing
  • delegate
  • direct booking

Resolution


To resolve this issue, force the regeneration of hidden free/busy information in the mailbox.

Notes

  • After you follow the steps in this section, you may have to reconfigure settings that are related to the following features:
    • Free/busy publishing
    • Delegates
    • Direct booking
  • The steps in this section must be applied on the mailbox of the user who owns the Calendar folder. This is the mailbox on which you try to create the calendar items, use the /cleanfreebusy switch, or configure the delegate settings.


To force the regeneration of hidden free/busy information in the mailbox, follow these steps:

  1. Exit Outlook.
  2. Make sure that there is an online mode profile for the mailbox.

    Note If there is no online mode profile, use the Mail item in Control Panel to create an online mode profile for the mailbox.
  3. Download the MFCMapi tool. To do this, visit the following Microsoft Web site:
  4. Start the MfcMapi.exe program that you downloaded, and then click OK.
  5. On the Tools menu, click Options.
  6. Click to enable the check boxes the following two options, and then click OK.

    • Use the MDB_ONLINE flag when calling Open MsgStore
    • Use the MAPI_NO_CACHE flag when calling OpenEntry

  7. On the Session menu, click Logon.
  8. In the Profile Name list, select the profile for the mailbox, and then click OK.
  9. Double-click the appropriate Microsoft Exchange Message Store.
  10. In the navigation pane, click Root Container.
  11. In the details pane, right-click PR_FREEBUSY_ENTRYIDS, click Delete Property, and then click OK.
  12. In the navigation pane, expand Root Container, expand Top of Information Store, and then click Inbox.
  13. In the details pane, right-click PR_FREEBUSY_ENTRYIDS, click Delete Property, and then click OK.
  14. Clean your local free/busy data. To do this, follow the steps for your version of Outlook.

    Outlook 2013 and later versions:
    1. In the navigation pane, expand Root Container.
    2. Double-click Freebusy Data.
    3. In the upper pane, find the item with the Subject of LocalFreebusy. Right-click it, and then click Delete message.
    4. For Deletion style, select Permanent delete passing DELETE_HARD_DELETE (unrecoverable), and then click OK.


    Outlook 2010 and earlier versions:
    1. Press Windows Key + R to open a Run dialog box. Type outlook.exe /cleanfreebusy, and then click OK.

  15. Close all of the MFCMapi windows.

Additional steps

Outlook 2010 and later versions


For the free/busy publishing feature
  1. Start Outlook.
  2. On the File tab, click Options, and then click Calendar.
  3. Click Free/Busy Options, and then click Other Free/Busy.
  4. In the Free/Busy Options dialog box, change the Publish <x> month(s) of Calendar free/busy information setting to a value that differs from the current setting.

    NoteIf you do not change the Publish month(s) of Calendar free/busy information setting value, Outlook does not update the hidden free/busy information. 

  5. Click OK three times.
  6. On the File tab, click Exit.
For the delegates feature
  1. Start Outlook.
  2. On the File tab, click Account Settings, and then click Delegate Access.
  3. Select the delegate that you want to reconfigure, and then click Permissions.
  4. Click to select the options that you want in the Delegate Permissions dialog box, and then click OK.
  5. Repeat step 3 and step 4 for all delegates.
  6. Click OK.
  7. On the File tab, click Exit.
For the direct booking feature
  1. Start Outlook.
  2. On the File tab, click Options, and then click Calendar.
  3. In Outlook 2016 or 2013, click Auto Accept/Decline, or in Outlook 2010, click Resource Scheduling.
  4. Click to select the check boxes that you want.
  5. Click OK two times.
  6. On the File menu, click Exit.

Outlook 2007 and Outlook 2003


If you have any custom settings that are related to the free/busy publishing feature, the delegates feature, or the direct booking feature, follow the appropriate steps.
For the free/busy publishing feature
  1. Start Outlook.
  2. On the Tools menu, click Options.
  3. Click the Preferences tab, and then click Calendar Options in the Calendar area.
  4. Click Free/Busy Options in the Advanced options area.
  5. In the Options area, change the Publish month(s) of Calendar free/busy information on the server setting value to a value that differs from the current setting.

    Note If you do not change the Publish month(s) of Calendar free/busy information on the server setting value, Outlook does not update the hidden free/busy information.
  6. Click OK three times.
  7. On the File menu, click Exit.
For the delegates feature
  1. Start Outlook.
  2. On the Tools menu, click Options, and then click the Delegates tab.
  3. Select the delegate that you want to reconfigure, and then click Permissions.
  4. Click to select the check boxes that you want in the Delegate Permissions dialog box.
  5. Repeat step 3 and step 4 for all delegates.
  6. Click OK two times.
  7. On the File menu, click Exit.
For the direct booking feature
  1. Start Outlook.
  2. On the Tools menu, click Options.
  3. Click the Preferences tab, and then click Calendar Options in the Calendar area.
  4. In the Advanced options area, click Resource Scheduling, and then click to select the check boxes that you want in the Resource Scheduling dialog box.
  5. Click OK three times.
  6. On the File menu, click Exit.
Properties

Article ID: 958443 - Last Review: Oct 18, 2016 - Revision: 1

Outlook 2016, Microsoft Outlook 2013, Microsoft Outlook 2010, Microsoft Office Outlook 2007, Microsoft Office Outlook 2003

Feedback