Symptoms
In Microsoft BizTalk Server 2006 and in Microsoft BizTalk 2006 R2, the PurgeSubscriptionsJob_BizTalkMsgBoxDB SQL Server Agent job runs to clear unused subscription predicates from the BizTalkMsgBoxDb database.
However, the NotEqualsPredicates table of the BizTalkMsgBoxDB database is never cleared. Therefore, after BizTalk Server runs for some time, the NotEqualsPredicates table grows very large.
Note Subscription predicates are comparison statements that are created when you create a subscription.
However, the NotEqualsPredicates table of the BizTalkMsgBoxDB database is never cleared. Therefore, after BizTalk Server runs for some time, the NotEqualsPredicates table grows very large.
Note Subscription predicates are comparison statements that are created when you create a subscription.
Cause
This problem occurs because of a problem in the stored procedure for the PurgeSubscriptionsJob_BizTalkMsgBoxDb SQL Server Agent job.
Resolution
After you apply this hotfix, this problem does not occur for new created entries in the NotEqualsPredicates table. However, it does not clear existing unused subscription predicates in the NotEqualsPredicates table. You might need to contact Microsoft Customer Service and Support to help clear the old entries.
If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.
Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.Known issue
Some BizTalk databases may not be updated if you change the BizTalk Server group name before you apply this hotfix package. To avoid this issue, rename the BizTalk Server group back to the following default name before you apply the hotfix:
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.
Hotfix information
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.
Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Known issue
Some BizTalk databases may not be updated if you change the BizTalk Server group name before you apply this hotfix package. To avoid this issue, rename the BizTalk Server group back to the following default name before you apply the hotfix:
BizTalk Group
Prerequisites
You must have Microsoft BizTalk Server 2006 or BizTalk Server 2006 R2 installed to apply this hotfix.Restart requirement
You do not have to restart the computer after you apply this hotfix.Hotfix replacement information
This hotfix does not replace any other hotfixes.File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.File information for BizTalk Server 2006
| File name | File version | File size | Date | Time | Platform |
|---|---|---|---|---|---|
| Msgboxlogic.sql | Not applicable | 544,606 | 05-Jun-2009 | 14:51 | Not applicable |
File information for BizTalk Server 2006 R2
| File name | File version | File size | Date | Time | Platform |
|---|---|---|---|---|---|
| Msgboxlogic.sql | Not applicable | 568,692 | 08-Jul-2009 | 17:28 | Not applicable |
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.
Installation notes
To install this hotfix, you must log on the BizTalk server as a local administrator and as a BizTalk Administrator. You should also be a member of the sysadmin fixed server role in the back-end SQL Server.
Before you install this hotfix, do the following preparations:
- Full backup of databases to be able to roll back.
- Stop all BizTalk host instances -
- Stop SQL Server Agent service
- If you use HTTP, SOAP, WSE or WCF adapters, stop the Internet Information Services (IIS) service by running IISRESET/STOP.
- Start the SQL Server Agent service.
- Start BizTalk host instances that were stopped before installation.
- If you use HTTP, SOAP, WSE or WCF adapters, start the IIS service by running IISRESET/START.
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
More Information
For more information about subscriptions in BizTalk Server 2006, visit the following Microsoft Web site:
For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates