Slow performance when you apply a filter to a form that is based on a large table in Microsoft Dynamics NAV 4.0 Service Pack 3 and Microsoft Dynamics NAV 5.0 Service Pack 1

Rapidly Published articles provide information directly from within the Microsoft support organization. The information that is contained herein is created in response to emerging or unique topics, or is intended to supplement other Knowledge Base information.

Symptoms

When you apply a filter to a form that is based on a large table in Microsoft Dynamics NAV 4.0 Service Pack 3 and Microsoft Dynamics NAV 5.0 Service Pack 1, you experience slow performance.

Cause

This problem occurs because the cursor type is changed from Fast Forward (FFO) to Dynamic.
Note For the Dynamics cursor type, Microsoft SQL Server is more likely to use an index that is based on the "ORDER BY" clause instead of the "WHERE" clause. When a user queries data in a certain order without a matching index, a table scan is generated on Microsoft SQL Server and the Fast Forward (FFO) cursor type is needed.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. There is a "Hotfix download available" section at the top of this Knowledge Base article. If you are encountering an issue downloading, installing this hotfix, or have other technical support questions, contact your partner or, if enrolled in a support plan directly with Microsoft, you can contact technical support for Microsoft Dynamics and create a new support request. To do this, visit the following Microsoft Web site: You can also contact technical support for Microsoft Dynamics by phone using these links for country specific phone numbers. To do this, visit one of the following Microsoft Web sites:

PartnersCustomersIn special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to any additional support questions and issues that do not qualify for the specific update in question.




How to obtain the Microsoft Dynamics NAV hotfix or update files

After you request a Microsoft Dynamics NAV hotfix or an update file from Technical Support for Microsoft Dynamics, a hyperlink will be sent to you in an e-mail.

The e-mail will contain a hyperlink and a password. You can use the hyperlink to download the Microsoft Dynamics NAV hotfix or the update files. When you click the hyperlink, the File Download – Security Warning dialog box opens. Then, you are prompted to run, to save, or to cancel the download.

If you click Run, the files start the download and the extraction process. You must specify a folder for the new files, and then provide the password.

If you click
Save, you must specify a path for saving the compressed file. When you open the file that you saved, you are prompted to specify a path for the files. You must then provide the password provided in the e-mail.


If you click Cancel, the download process stops.

Installation information

Prerequisites

You must have Microsoft Dynamics NAV 4.0 Service Pack 3 or Microsoft Dynamics NAV 5.0 Service Pack 1 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

How to install a Microsoft Dynamics NAV hotfix or an update file

The Microsoft Dynamics NAV platform hotfixes and updates are made available as single files. To install a Microsoft Dynamics NAV hotfix or an update, you must replace the existing Microsoft Dynamics NAV installation files with the hotfix or the update files. To do this, follow these steps.

For Microsoft Dynamics NAV 4.0 Service Pack 3 (SP3)

Step 1: Replace the Microsoft Dynamics NAV client installation file

In the Microsoft Dynamics NAV client installation, replace the following files by using the hotfix or the update file.
File nameFile versionFile sizeDateTimePlatform
Dbm.dll4.0.3.29113341,81611-May-200919:08x86
Fin.exe4.0.3.291138,120,12011-May-200919:08x86
Finhlink.exe4.0.3.29113116,55211-May-200919:08x86
Finsql.exe4.0.3.291138,169,28011-May-200919:08x86
Nc_netb.dll4.0.3.2911375,58411-May-200919:08x86
Nc_tcp.dll4.0.3.2911379,68011-May-200919:08x86
Nc_tcps.dll4.0.3.2911387,87211-May-200919:08x86
Ndbcs.dll4.0.3.291131,091,39211-May-200919:08x86
Slave.exe4.0.3.2911391,96811-May-200919:08x86
Note The Microsoft Dynamics NAV client is usually installed in the following directory.

C:\Program Files\Microsoft Business Solutions-Navision\Client\

To replace the existing Microsoft Dynamics NAV files, follow these steps:
  1. Close Microsoft Dynamics NAV.
  2. Locate the Microsoft Dynamics NAV client installation directory.
  3. Copy the files that you downloaded.
  4. Paste the files that you downloaded into the Microsoft Dynamics NAV client installation directory.
  5. In the Confirm File Replace dialog box, click Yes to overwrite the files in the installation directory.

Step 2: Replace the Microsoft Dynamics NAV Application Server installation file

In the Microsoft Dynamics NAV Application Server installation, replace the following files.
File nameFile versionFile sizeDateTimePlatform
Dbm.dll4.0.3.29113341,81611-May-200919:07x86
Nas.exe4.0.3.291131,419,06411-May-200919:08x86
Nassql.exe4.0.3.291131,468,22411-May-200919:08x86
Ndbcs.dll4.0.3.291131,091,39211-May-200919:07x86
Slave.exe4.0.3.2911391,96811-May-200919:07x86
To replace the files, follow these steps.
  1. Stop the Microsoft Dynamics NAV Application Server.
  2. Locate the Microsoft Dynamics NAV Application Server installation directory. The Microsoft Dynamics NAV Application Server is usually installed in the following directory.
    C:\Program Files\Microsoft Business Solutions-Navision\Application Server\
  3. Copy the files that you downloaded.
  4. Paste the files that you downloaded into the Microsoft Dynamics NAV Application Server installation directory.
  5. Click Yes to overwrite the files in the directory.
  6. Start the Microsoft Dynamics NAV Application Server.

For Microsoft Dynamics NAV 5.0 Service Pack 1(SP1)

Step 1: Replace the Microsoft Dynamics NAV client installation file

In the Microsoft Dynamics NAV client installation, replace the following files by using the hotfix or the update file.
File nameFile versionFile sizeDateTimePlatform
Dbm.dll5.0.29118.0440,13611-May-200920:31x86
Fin.exe5.0.29118.010,733,36811-May-200920:31x86
Finhlink.exe5.0.29118.0345,93611-May-200920:31x86
Finsql.exe5.0.29118.010,798,91211-May-200920:31x86
Nc_netb.dll5.0.29118.0108,35211-May-200920:31x86
Nc_tcp.dll5.0.29118.0108,35211-May-200920:31x86
Nc_tcps.dll5.0.29118.0153,40811-May-200920:31x86
Ndbcs.dll5.0.29118.01,288,01611-May-200920:31x86
Slave.exe5.0.29118.0157,52011-May-200920:31x86
Note The Microsoft Dynamics NAV client is usually installed in the following directory.

C:\Program Files\Microsoft Dynamics NAV\CSIDE Client\

To replace the existing Microsoft Dynamics NAV files, follow these steps:
  1. Close Microsoft Dynamics NAV.
  2. Locate the Microsoft Dynamics NAV client installation directory.
  3. Copy the files that you downloaded.
  4. Paste the files that you downloaded into the Microsoft Dynamics NAV client installation directory.
  5. In the Confirm File Replace dialog box, click Yes to overwrite the files in the installation directory.

Step 2: Replace the Microsoft Dynamics NAV Application Server installation file

In the Microsoft Dynamics NAV Application Server installation, replace the following files.
File nameFile versionFile sizeDateTimePlatform
Dbm.dll5.0.29118.0440,12011-May-200920:31x86
Nas.exe5.0.29118.01,857,35211-May-200920:31x86
Nassql.exe5.0.29118.01,922,88011-May-200920:31x86
Ndbcs.dll5.0.29118.01,288,01611-May-200920:31x86
Slave.exe5.0.29118.0157,52011-May-200920:31x86
To replace the files, follow these steps.
  1. Stop the Microsoft Dynamics NAV Application Server.
  2. Locate the Microsoft Dynamics NAV Application Server installation directory.

    Note Typically, the Microsoft Dynamics NAV Application Server is installed in the following directory:
    C:\Program Files\Microsoft Dynamics NAV\Application Server\
  3. Copy the files that you downloaded.
  4. Paste the files that you downloaded into the Microsoft Dynamics NAV Application Server installation directory.
  5. Click Yes to overwrite the files in the directory.
  6. Start the Microsoft Dynamics NAV Application Server.

Status

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.
After this update, Microsoft Dynamics NAV use Fast Forward (FFO) cursor type when a transaction is in the browse mode. Meanwhile, Microsoft Dynamics NAV use Dynamic cursor type when the transaction is in a write mode.

More Information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Article ID: 971172 - Last Review: Jan 30, 2017 - Revision: 2

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