Symptoms
In a Microsoft System Center Operations Manager environment, one or more management servers that host the following roles, together with those management servers' managed devices, may appear dimmed or grayed out in the Operations Console:
Note This event may report the issue with other Operations Manager processes, depending on the affected role.
- Root Management Server
- Management Server
- Gateway Server
- Agent
Note This event may report the issue with other Operations Manager processes, depending on the affected role.
Cause
This problem typically occurs in a large Operations Manager environment in which a management server or an agent computer is managing many workflows. This situation may occur for one of the following reasons:
- Many Management Packs are installed.
- A management server or an agent is acting as a proxy for many devices.
Resolution
Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
After you apply the registry change, restart the HealthService service.
Notes
322756 How to back up and restore the registry in Windows
To resolve the problem, apply the following registry setting on the computers that host the affected roles:Subkey: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HealthService\Parameters
Type: REG_DWORD
Name: Persistence Version Store Maximum
Value: Number of 16-kilobyte pages
Base: Decimal
The default size of the version store depends on the Operations Manager role and is defined as the number of 16-kilobyte pages to allocate in memory. The default values are as follows:Type: REG_DWORD
Name: Persistence Version Store Maximum
Value: Number of 16-kilobyte pages
Base: Decimal
- Agent (workstation operating systems): 640 (10 megabytes)
- Agent (server operating systems): 1920 (30 megabytes)
- Management Server: 5120 (80 megabytes)
After you apply the registry change, restart the HealthService service.
Notes
- A larger version store size requires additional memory to be allocated.
- If the HealthService is running lots of workflows, this registry value must be set even larger than the recommended size.
- For other issues where some of these symptoms are similar see Troubleshooting gray agent states in System Center Operations Manager