Error message when you try to install Service Pack 2 for Windows Server 2008 or for Windows Vista: "ERROR_INVALID_PARAMETER(0x80070057)"


Symptoms


When you try to install Service Pack 2 (SP2) for Windows Server 2008 or for Windows Vista, you receive the following error message:
Fail to install Service Pack

Invalid Parameter

Error: ERROR_INVALID_PARAMETER(0x80070057)
You receive the error message if you try to install Service Pack 2 (SP2) for Windows Server 2008 or for Windows Vista after you install the August 2009 Windows Vista and Windows Server 2008 Application Compatibility Update (KB972036).

Cause


This problem can occur because of a known issue that affects the update (KB972036).

Resolution


To resolve this problem, install the latest version of the August 2009 Windows Vista and Windows Server 2008 Application Compatibility Update. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

972036 August 2009 Windows Vista and Windows Server 2008 Application Compatibility Update

Workaround


If you do not want to install the latest version of the update, you can work around this problem, instead. To do this, uninstall the August 2009 Windows Vista and Windows Server 2008 Application Compatibility Update, and then install Service Pack 2 for Windows Server 2008 or for Windows Vista.

To uninstall the August 2009 Windows Vista and Windows Server 2008 Application Compatibility Update, follow these steps:
  1. Click Start, and then click Control Panel.
  2. Under the Programs section, click Uninstall a program.
  3. In the Tasks list in the navigation pane, click View installed updates.
  4. Click Update for Microsoft Windows (KB972036), and then click Uninstall.
  5. Click Yes when you are prompted for confirmation.
    Note If you are prompted for an administrator password or for confirmation, type the administrator password or click Yes.
  6. Restart the system when you are prompted.
Note You can reinstall the August 2009 Windows Vista and Windows Server 2008 Application Compatibility Update after you have installed Service Pack 2 for Windows Server 2008 or for Windows Vista.