Error message when you select an Automation object in Microsoft Dynamics NAV 5.0: "The length of the text string exceeds the size of the string buffer"

Applies to: Microsoft Dynamics NAV 5.0

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This article applies to Microsoft Dynamics NAV for all countries and all language locales.

Symptoms


When you select an Automation object from an Automation object list in Microsoft Dynamics NAV 5.0, you receive the following error message:
The length of the text string exceeds the size of the string buffer.
This problem occurs if the object name exceeds 30 characters.

Cause


This problem occurs because the Automation method names and the property names are truncated to 30 characters by the object save function, the object restore function, the copy function or the paste function.

Resolution


Hotfix information

A supported hotfix is available from Microsoft. There is a "Hotfix download available" section at the top of this Knowledge Base article. If you are encountering an issue downloading, installing this hotfix, or have other technical support questions, contact your partner or, if enrolled in a support plan directly with Microsoft, you can contact technical support for Microsoft Dynamics and create a new support request. To do this, visit the following Microsoft Web site: You can also contact technical support for Microsoft Dynamics by phone using these links for country specific phone numbers. To do this, visit one of the following Microsoft Web sites:

PartnersCustomersIn special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to any additional support questions and issues that do not qualify for the specific update in question.




How to obtain the Microsoft Dynamics NAV hotfix or update files

After you request a Microsoft Dynamics NAV hotfix, a hyperlink will be sent to you in an e-mail.


The e-mail will contain a hyperlink and a password. You can use the hyperlink to download the Microsoft Dynamics NAV hotfix or the update files. When you click the hyperlink, the File Download – Security Warning dialog box opens. Then, you are prompted to run, to save, or to cancel the download.


If you click Run, the files start the download and the extraction process. You must specify a folder for the new files, and then provide the password.


If you click Save, you must specify a path for saving the compressed file. When you open the file that you saved, you are prompted to specify a path for the files. Then, you must provide the password provided in the e-mail.


If you click Cancel, the download process stops.



How to install a Microsoft Dynamics NAV hotfix or an update file

The Microsoft Dynamics NAV platform hotfixes and updates are made available as single files. To install a Microsoft Dynamics NAV hotfix or an update, you must replace the existing Microsoft Dynamics NAV installation files with the hotfix or the update files. To do this, follow these steps.

Step 1: Replace the Microsoft Dynamics NAV Client installation file

In the Microsoft Dynamics NAV Client installation, replace the following files by using the hotfix or the update file.
File nameFile versionFile sizeDateTimePlatform
Dbm.dll5.0.29902.0440,12030-Sep-200922:08x86
Fin.exe5.0.29902.010,745,65630-Sep-200922:08x86
Finhlink.exe5.0.29902.0345,92830-Sep-200922:08x86
Finsql.exe5.0.29902.010,811,20030-Sep-200922:08x86
Nc_netb.dll5.0.29902.0108,35230-Sep-200922:08x86
Nc_tcp.dll5.0.29902.0108,35230-Sep-200922:08x86
Nc_tcps.dll5.0.29902.0153,40830-Sep-200922:08x86
Ndbcs.dll5.0.29902.01,288,00030-Sep-200922:08x86
Slave.exe5.0.29902.0157,50430-Sep-200922:08x86

To replace the existing Microsoft Dynamics NAV files, follow these steps:
  1. Close Microsoft Dynamics NAV.
  2. Locate the Microsoft Dynamics NAV Client installation directory. The Microsoft Dynamics NAV Client is usually installed in the following directory:
    C:\Program Files\Microsoft Dynamics NAV\CSIDE Client\
  3. Copy the files that you downloaded.
  4. Paste the files that you downloaded into the Microsoft Dynamics NAV Client installation directory.
  5. When you are prompted, click Yes to overwrite the files in the installation directory.

Step 2: Replace the Microsoft Dynamics NAV Application Server installation file

If you have Microsoft Dynamics NAV Application Server installed, in the Microsoft Dynamics NAV Application Server installation, replace the following files by using the hotfix or the update file.
File nameFile versionFile sizeDateTimePlatform
Dbm.dll5.0.29902.0440,12030-Sep-200922:07x86
Nas.exe5.0.29902.01,865,52830-Sep-200922:08x86
Nassql.exe5.0.29902.01,926,97630-Sep-200922:08x86
Ndbcs.dll5.0.29902.01,288,00030-Sep-200922:07x86
Slave.exe5.0.29902.0157,50430-Sep-200922:07x86
To replace the files, follow these steps.
  1. Stop the Microsoft Dynamics NAV Application Server.
  2. Locate the Microsoft Dynamics NAV Application Server installation directory. The Microsoft Dynamics NAV Application Server is usually installed in the following directory:
    C:\Program Files\Microsoft Dynamics NAV\Application Server\
  3. Copy the files that you downloaded.
  4. Paste the files that you downloaded into the Microsoft Dynamics NAV Application Server installation directory.
  5. When you are prompted, click Yes to overwrite the files in the installation directory.
  6. Start the Microsoft Dynamics NAV Application Server.

Status


Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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