Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

RAPID PUBLISHING ARTICLES PROVIDE INFORMATION DIRECTLY FROM WITHIN THE MICROSOFT SUPPORT ORGANIZATION. THE INFORMATION THAT IS CONTAINED HEREIN IS CREATED IN RESPONSE TO EMERGING OR UNIQUE TOPICS, OR IS INTENDED TO SUPPLEMENT OTHER KNOWLEDGE BASE INFORMATION.

This article applies to Microsoft Dynamics NAV for all countries and all language locales.

Symptoms

After you run a report in the Role Tailored Client (RTC) in Microsoft Dynamics NAV 2009 Service Pack 1, you experience slow performance in pages. It takes many times to open a page.


Note This problem does not occur in Microsoft Dynamics NAV 2009 without Service Pack 1.

Cause

This problem occurs because not all memory is released after you run a report. Therefore, the RTC consumes higher memory.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. There is a "Hotfix download available" section at the top of this Knowledge Base article. If you are encountering an issue downloading, installing this hotfix, or have other technical support questions, contact your partner or, if enrolled in a support plan directly with Microsoft, you can contact technical support for Microsoft Dynamics and create a new support request. To do this, visit the following Microsoft Web site:

https://mbs.microsoft.com/support/newstart.aspx You can also contact technical support for Microsoft Dynamics by phone using these links for country specific phone numbers. To do this, visit one of the following Microsoft Web sites:

Partners

https://mbs.microsoft.com/partnersource/resources/support/supportinformation/Global+Support+ContactsCustomers

https://mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htmIn special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to any additional support questions and issues that do not qualify for the specific update in question.



How to obtain the Microsoft Dynamics NAV hotfix or update files

After you request a Microsoft Dynamics NAV hotfix, a hyperlink will be sent to you in an e-mail.


The e-mail will contain a hyperlink and a password. You can use the hyperlink to download the Microsoft Dynamics NAV hotfix or the update files. When you click the hyperlink, the File Download – Security Warning dialog box opens. Then, you are prompted to run, to save, or to cancel the download.


If you click Run, the files start the download and the extraction process. You must specify a folder for the new files, and then provide the password.


If you click Save, you must specify a path for saving the compressed file. When you open the file that you saved, you are prompted to specify a path for the files. Then, you must provide the password provided in the e-mail.


If you click Cancel, the download process stops.



How to install a Microsoft Dynamics NAV hotfix or an update file

The Microsoft Dynamics NAV platform hotfixes and updates are made available as single files. To install a Microsoft Dynamics NAV hotfix or an update, you must replace the existing Microsoft Dynamics NAV installation files with the hotfix or the update files. To do this, follow these steps.

Step 1: Replace the files in the Microsoft Dynamics NAV Classic Client installation

In the Microsoft Dynamics NAV Classic Client installation, replace the following files by using the hotfix or the update file.

File name

File version

File size

Date

Time

Platform

Dbm.dll

6.0.29994.0

427,832

13-Oct-2009

20:49

x86

Fin.exe

6.0.29994.0

12,598,584

13-Oct-2009

20:49

x86

Finhlink.exe

6.0.29994.0

452,424

13-Oct-2009

20:49

x86

Finsql.exe

6.0.29994.0

12,713,792

13-Oct-2009

20:49

x86

Nc_netb.dll

6.0.29994.0

96,576

13-Oct-2009

20:49

x86

Nc_tcp.dll

6.0.29994.0

98,624

13-Oct-2009

20:49

x86

Nc_tcps.dll

6.0.29994.0

141,120

13-Oct-2009

20:49

x86

Ndbcs.dll

6.0.29994.0

1,348,928

13-Oct-2009

20:49

x86

Slave.exe

6.0.29994.0

152,384

13-Oct-2009

20:49

x86

To replace the existing Microsoft Dynamics NAV files, follow these steps:

  1. Close the Microsoft Dynamics NAV Classic Client.

  2. Locate the Microsoft Dynamics NAV Classic Client installation directory. The Microsoft Dynamics NAV Classic Client is usually installed in the following directory:

    C:\Program Files\Microsoft Dynamics NAV\60\Classic

  3. Copy the files that you downloaded.

  4. Paste the files that you downloaded into the Microsoft Dynamics NAV Classic Client installation directory.

  5. Click Yes to overwrite the files in the directory.

Step 2: Replace the files in the Microsoft Dynamics NAV Role Tailored Client installation

In the Microsoft Dynamics NAV Role Tailored Client installation, replace the following files by using the hotfix or the update file.

File name

File version

File size

Date

Time

Platform

Microsoft.dynamics.framework.patterns.dll

1.3.10803.29

71,640

13-Oct-2009

06:30

x86

Microsoft.dynamics.framework.ui.dll

1.3.10803.29

698,312

13-Oct-2009

06:30

x86

Microsoft.dynamics.framework.ui.mapping.dll

1.3.10803.29

104,408

13-Oct-2009

06:30

x86

Microsoft.dynamics.framework.ui.navigation.dll

1.3.10803.29

34,784

13-Oct-2009

06:30

x86

Microsoft.dynamics.framework.ui.ux2006.dll

1.3.10803.29

88,024

13-Oct-2009

06:30

x86

Microsoft.dynamics.framework.ui.ux2006.winforms.dll

1.3.10803.29

63,464

13-Oct-2009

06:30

x86

Microsoft.dynamics.framework.ui.windows.dll

1.3.10803.29

83,928

13-Oct-2009

06:30

x86

Microsoft.dynamics.framework.ui.winforms.controls.dll

1.3.10803.29

2,111,472

13-Oct-2009

06:30

x86

Microsoft.dynamics.framework.ui.winforms.dll

1.3.10803.29

686,048

13-Oct-2009

06:30

x86

Microsoft.dynamics.nav.client.builder.dll

6.0.29994.0

198,528

13-Oct-2009

20:46

x86

Microsoft.dynamics.nav.client.exe

6.0.29994.0

149,360

13-Oct-2009

20:46

x86

Microsoft.dynamics.nav.client.interop.communicator.dll

1.0.559.183

75,680

13-Oct-2009

20:46

x86

Microsoft.dynamics.nav.client.serviceconnection.dll

6.0.29994.0

100,248

13-Oct-2009

20:46

x86

Microsoft.dynamics.nav.client.ui.dll

6.0.29994.0

505,720

13-Oct-2009

20:46

x86

Microsoft.dynamics.nav.client.winforms.dll

6.0.29994.0

337,792

13-Oct-2009

20:46

x86

Microsoft.dynamics.nav.client.winforms.tlb

Not applicable

2,644

13-Oct-2009

11:57

Not applicable

Microsoft.dynamics.nav.language.dll

6.0.29994.0

1,963,888

13-Oct-2009

20:46

x86

Microsoft.dynamics.nav.types.dll

6.0.29994.0

563,056

13-Oct-2009

20:46

x86

Microsoft.office.interop.outlook.dll

10.0.4504.0

395,128

13-Oct-2009

20:49

x86


To replace these files, follow these steps:

  1. Close the Microsoft Dynamics NAV Role Tailored Client.

  2. Locate the Microsoft Dynamics NAV Role Tailored Client installation directory. The Microsoft Dynamics NAV Role Tailored Client is usually installed in the following directory:

    C:\Program Files\Microsoft Dynamics NAV\60\RoleTailored Client

  3. Copy the files that you downloaded.

  4. Paste the files that you downloaded into the Microsoft Dynamics NAV Role Tailored Client installation directory.

  5. Click Yes to overwrite the files in the directory.

Step 3: Replace the files in the Microsoft Dynamics NAV Server installation

In the Microsoft Dynamics NAV Server installation, replace the following files by using the hotfix or the update file.

File name

File version

File size

Date

Time

Platform

Httpcfg.exe

5.2.3790.0

22,336

13-Oct-2009

20:49

x86

Microsoft.dynamics.nav.language.dll

6.0.29994.0

1,963,888

13-Oct-2009

20:46

x86

Microsoft.dynamics.nav.ncl.dll

6.0.29994.0

599,912

13-Oct-2009

20:46

x86

Microsoft.dynamics.nav.server.exe

6.0.29994.0

141,168

13-Oct-2009

20:46

x86

Microsoft.dynamics.nav.server.exe.config

Not applicable

211

25-Aug-2009

16:51

Not applicable

Microsoft.dynamics.nav.service.dll

6.0.29994.0

145,264

13-Oct-2009

20:46

x86

Microsoft.dynamics.nav.service.runtime.dll

6.0.29994.0

75,648

13-Oct-2009

20:46

x86

Microsoft.dynamics.nav.service.webservices.dll

6.0.29994.0

145,288

13-Oct-2009

20:46

x86

Microsoft.dynamics.nav.types.dll

6.0.29994.0

563,056

13-Oct-2009

20:46

x86

Microsoft.dynamics.nav.watson.dll

6.0.29994.0

42,864

13-Oct-2009

20:46

x86

Nclcsrt.etx

Not applicable

89,525

13-Oct-2009

08:26

Not applicable

Nclcsrt.stx

Not applicable

91,724

13-Oct-2009

08:26

Not applicable

Nclcsrts.dll

6.0.29994.0

1,435,976

13-Oct-2009

20:49

x86

Ndbcs.dll

6.0.29994.0

1,348,928

13-Oct-2009

20:49

x86


To replace these files, follow these steps:

  1. Stop the Microsoft Dynamics NAV Server.

  2. Locate the Microsoft Dynamics NAV Server installation directory. The Microsoft Dynamics NAV Server is usually installed in the following directory:

    C:\Program Files\Microsoft Dynamics NAV\60\Service

  3. Copy the files that you downloaded.

  4. Paste the files that you downloaded into the Microsoft Dynamics NAV Server installation directory.

  5. Click Yes to overwrite the files in the directory.

  6. Start the Microsoft Dynamics NAV Server.

In the Common Files folder, replace the following files by using the hotfix or the update files.

File name

File version

File size

Date

Time

Platform

Customization.xml

Not applicable

1,115

25-Aug-2009

16:40

Not applicable

Msoutl.olb

11.0.5510.0

200,248

25-Aug-2009

16:40

Not applicable


To replace the existing files, follow these steps:

  1. Locate the following folder in the Common Files directory:

    C:\Program Files\Common Files\Microsoft Dynamics NAV\OLSync

  2. Copy the files that you downloaded.

  3. Paste the files that you downloaded into the Common Files directory.

  4. Click Yes to overwrite the files in the directory.

In the Windows\System32 folder, replace the following files by using the hotfix or the update files.

File name

File version

File size

Date

Time

Platform

Cdo.dll

6.5.7940.0

775,480

13-Oct-2009

20:49

x86

Gapi32.dll

6.5.7940.0

71,488

13-Oct-2009

20:49

x86


To replace the existing files, follow these steps:

  1. Locate the following Windows\System32 directory:

    C:\Windows\System32

  2. Copy the files that you downloaded.

  3. Paste the files that you downloaded into the Windows\System32 directory.

  4. Click Yes to overwrite the files in the directory.

Status

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

MICROSOFT AND/OR ITS SUPPLIERS MAKE NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY, THE RELIABILITY OR THE ACCURACY OF THE INFORMATION THAT IS CONTAINED IN THE DOCUMENTS AND THE RELATED GRAPHICS PUBLISHED ON THIS WEB SITE (THE “MATERIALS”) FOR ANY PURPOSE.

THE MATERIALS MAY INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS AND MAY BE REVISED AT ANY TIME WITHOUT NOTICE. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, MICROSOFT AND/OR ITS SUPPLIERS DISCLAIM AND EXCLUDE ALL REPRESENTATIONS, WARRANTIES, AND CONDITIONS WHETHER EXPRESS, IMPLIED OR STATUTORY, INCLUDING BUT NOT LIMITED TO REPRESENTATIONS, WARRANTIES, OR CONDITIONS OF TITLE, NON-INFRINGEMENT, SATISFACTORY CONDITION OR QUALITY, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WITH RESPECT TO THE MATERIALS.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×