Stop error message when you run an application that has a WS_CHILD styled message-only window in Windows Server 2003 SP2 or in Windows XP Professional x64 Edition SP2: "Stop error code 0x0000008E (KERNEL_MODE_EXCEPTION_NOT_HANDLED)"

Applies to: Microsoft Windows Server 2003 Service Pack 2Microsoft Windows Server 2003 Web EditionMicrosoft Windows Server 2003 Datacenter Edition (32-bit x86) More

Not sure if this is the right fix? We've added this issue to our memory dump diagnostic which can confirm.

Symptoms


Consider the following scenario:
  • You have a computer that is running Windows Server 2003 Service Pack 2 (SP2) or Windows XP Professional x64 Edition SP2.
  • You enable the Input Method Editor (IME) feature.
  • You run an application that meets the following requirements:
    • The first window of a thread in this application is a child window.
    • There is only one message-only window in the thread.
    • The message-only window is created in the WS_CHILD style.
  • The message-only window in the application is destroyed.
In this scenario, you receive a Stop error message that resembles one of following:
STOP 0X1000008e (0x00C0000005, parameter2, parameter3, parameter4) KERNEL_MODE_EXCEPTION_NOT_HANDLED_M
STOP 0x0000008E (0x00C0000005, parameter2, parameter3, parameter4) KERNEL_MODE_EXCEPTION_NOT_HANDLED
Notes
  • The last three parameters in this Stop error message may vary, depending on the configuration of the computer.
  • Not all "0x0000008E" Stop error messages are caused by this problem.

Cause


The Win32k.sys module accesses a handle to the parent window that is in the application. Before the module accesses the handle, the module does not check whether the value of the handle is NULL. Because of this behavior, the system is not prevented from accessing an invalid memory address when the value is NULL. Therefore, the Stop error occurs.

Resolution


Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 SP2 or Windows XP Professional x64 Edition SP2. For more information about how to obtain a Windows Server 2003 service pack or a Windows XP Professional x64 Edition service pack, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows XP and Windows Server 2003 file information note
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.46191,863,16814-Nov-200900:48x86
For all supported x64-based versions of Windows Server 2003 and of Windows XP Professional x64 Edition
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.46194,546,04815-Nov-200915:49x64
For all supported IA-64-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.46195,592,57615-Nov-200915:49IA-64

Workaround


To work around this issue, use one of the following methods.

Method 1

When you develop this application, do not use the WS_CHILD style to create the message-only window.

Method 2

Turn off advanced text services. To turn off advanced text services, follow these steps:
  1. Click Start, and then click Control Panel.
  2. Click Date, Time, Language, and Regional Options.
  3. Click Regional and Language Options.
  4. On the Languages tab, click Details.
  5. On the Advanced tab, select the Turn off advanced text services check box.
  6. Click OK. If you are prompted to confirm the change, click Yes, and then click OK.
Note The IME feature is disabled after you turn off advanced text services.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information about child windows and about message-only windows, visit the following Microsoft Developer Network (MSDN) Web site: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates