Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

When you run a Microsoft .NET Framework 2.0-based application that uses the AesCryptoServiceProvider class, a memory leak occurs.

Cause

This problem occurs because of the following two reasons.

Reason 1

Two native handles that are in a parent/child relationship in an AesCryptoServiceProvider object belong to separate managed objects. When the parent handle is disposed of first, the system cannot trace and then release all the memory that is owned by the child handle.

Reason 2

The AesCryptoServiceProvider object leaks a reference to an object in its ICryptoTransform interface.

Resolution

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

To download this hotfix from the MSDN Code Gallery, visit the following Microsoft website:

http://code.msdn.microsoft.com/KB981575Note The MSDN Code Gallery displays the languages for which the hotfix is available. If you do not see your language listed, it is because the Code Gallery resource page is not available for that language.

You can also download this hotfix from the following Microsoft website:

http://connect.microsoft.com/VisualStudio/Downloads/DownloadDetails.aspx?DownloadID=31185

Prerequisites

You must have the .NET Framework 2.0 Service Pack 2 (SP2) or the Microsoft .NET Framework 3.5 Service Pack 1 (SP1) installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply the hotfix if affected files are not being used.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

For all supported x86-based versions of Windows Server 2003, of Windows XP, of Windows Vista, and of Windows Server 2008

File name

File version

File size

Date

Time

Platform

System.core.dll

3.5.30729.4530

667,648

01-Apr-2010

09:55

x86

For all supported x64-based versions of Windows Server 2003, of Windows XP, of Windows Vista, and of Windows Server 2008

File name

File version

File size

Date

Time

Platform

System.core.dll

3.5.30729.4530

667,648

01-Apr-2010

09:55

x86

For all supported x86-based versions of Windows 7

File name

File version

File

size

Date

Time

Platform

System.core.dll

3.5.30729.5025

667,648

29-Apr-2010

23:55

x86

For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name

File version

File

size

Date

Time

Platform

System.core.dll

3.5.30729.5025

667,648

30-Apr-2010

00:31

x64

For all supported IA-64-based versions of Windows Server 2008 R2

File name

File version

File

size

Date

Time

Platform

System.core.dll

3.5.30729.5025

667,648

29-Apr-2010

23:50

IA-64

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×