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Err Msg: Drive C Contains Errors That Must Be Corrected...

This article was previously published under Q132883
SYMPTOMS
You may experience one of the following problems while using DriveSpace:
  • When you upgrade a compressed drive from DriveSpace to DriveSpace 3, you may receive the following error message:
    You cannot upgrade drive X because it contains errors. To upgrade this drive, first run ScanDisk on it, and then try again to upgrade it.

    ID Number: DRVSPACE 424
  • When you compress an existing uncompressed drive, you may receive the following error message:
    Drive X contains errors that must be corrected before the drive can be compressed. To correct them run ScanDisk.

    ID Number: DRVSPACE 306
  • When you uncompress a compressed drive, you may receive the following error message:
    Drive X contains errors that must be corrected before the drive can be uncompressed. To correct them, run ScanDisk.

    ID Number: DRVSPACE 307
  • When you create a new empty compressed drive, you may receive the following error message:
    Drive C contains errors that must be corrected before the drive can be used to create a new compressed drive. To correct them run ScanDisk.

    ID Number: DRVSPACE 308
CAUSE
These errors can occur if the drive contains a folder with a path thatcontains more than 66 characters. For example, the following path containsmore than 66 characters:
C:\Windows\Profiles\<username>\Startm~1\Programs\Winapp\Winword\Setup

RESOLUTION
To work around this problem, follow these steps:
  1. Start ScanDisk. Click the Automatically Fix Errors check box to clear it, and then begin checking the drive.
  2. When you receive the error message
    The <path> folder could not be opened in MS-DOS mode because its complete short name was longer than 66 characters.
    make a note of the path that is longer than 66 characters, and then click Ignore. If you receive more than one such message, note each path.
  3. After ScanDisk is finished, move each folder whose path contains more than 66 characters to another location with a shorter path.
  4. Perform the DriveSpace operation you want.
  5. After the DriveSpace operation is finished, move each folder that you moved in step 3 back to its original location.
MORE INFORMATION
This is not a limitation in Windows or DriveSpace. Windows allowspaths with more than 66 characters. However, MS-DOS does not allow theselong paths. When you use the Automatically Fix Errors option in ScanDisk,a path that is longer than 66 characters is considered valid to Windowsand invalid to MS-DOS.

ScanDisk does not try to fix the path because the path is valid to WindowsHowever, when DriveSpace runs in mini-Windows mode, a folder with apath longer than 66 characters cannot be processed correctly.

This situation may occur when you are using user profiles because of thelong directory structure that is created. User profiles can store theentire Start Menu directory structure, creating paths longer than 66characters.

NOTE: If you start your computer to Safe Mode Command Prompt Only and thenrun ScanDisk at a command prompt, you receive messages indicating thatyour hard disk contains bad clusters. When you are prompted to do so, movethe files to a new location, and then continue running ScanDisk.

NOTE: If ScanDisk for Windows does not give you an error message that thepath is too long even if the Automatically Fix Errors check box isselected, enable the "Report MS-DOS mode name length errors" in ScanDiskadvanced options.
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Article ID: 132883 - Last Review: 01/19/2007 13:26:30 - Revision: 1.2

Microsoft Windows 95, Microsoft Windows 98 Standard Edition

  • kberrmsg kbprb kbscandisk KB132883
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