Problems Printing to HP DeskJet Printer

This article was previously published under Q137996
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SYMPTOMS
After you upgrade to Windows 95, you may not be able to print to yourHewlett-Packard (HP) DeskJet printer. You may experience any of thefollowing symptoms:
  • When you try to print to the DeskJet printer, or to a file, you may receive
    "Out of memory"
    or
    "Not enough memory"
    error messages.
  • When you try to print to the DeskJet printer, you may receive an error message stating that the printer is offline.
  • When you try to install the HP DeskJet printer drivers included with Windows 95, you receive an error message stating that Unidrv.dll is already in use.
  • When you print to a Hewlett-Packard (HP) color DeskJet 5xx-series printer, you may receive the following error message:
    Cannot print to device LPT1
  • When you try to print from WordPad, you may receive the following error message:
    Could not start print job
  • When you try to print to the DeskJet printer, your entire document may be printed as random or unintelligible characters.
  • When you try to print to the DeskJet printer, graphics may be printed, but text may not.
  • When you try to print to the DeskJet printer, text may be printed, but graphics may not.
CAUSE
The Windows 3.1 drivers for the HP DeskJet printer were not successfullyupgraded to the Windows 95 versions.
RESOLUTION
To resolve this problem, follow these steps:

  1. Double-click the Printers icon in Control Panel.
  2. Right-click the HP DeskJet printer, and then click Delete on the menu that appears. If you receive a prompt stating that all the files associated with the printer will be removed, click OK.
  3. If there is more than one HP DeskJet printer in the Printers folder, repeat step 2 for each HP DeskJet printer.
  4. Locate and remove the following files in the Windows folder:
    Deskjet.ini
    Deskjetc.ini
    NOTE: Your computer may have only one of these files, or both.
  5. Locate and remove the following files in the Windows\System folder. To avoid deleting files that may be crucial to other HP components, delete only these files:
          DESKJETC.DRV      HPDSKJET.DRV      HPSETUP3.DLL      HPV1284.DLL      HPV500.HPC      HPV500C.HPC      HPV510.HPC      HPV520.HPC      HPV540_A.HPC      HPV540_B.HPC      HPV550C.HPC      HPV560C.HPC      HPV660C.HPC      HPVBG.EXE      HPVCM.HPM      HPVCNFIG.EXE      HPVDOS.DLL      HPVDSM.EXE      HPVEXT24.DLL      HPVHT.DLL      HPVMLC.DLL      HPVMLCH.EXE      HPVMON.DLL      HPVPML.DLL      HPVQP.DLL      HPVQPR.DLL      HPVRES.DLL      HPVTTPCL.DLL      HPVUI.DLL      HPVWCPS.DLL      HPVWIN.DLL      SCONFIG.DLL      TBKBASE.DLL      TBKCOMP.DLL      TBKNET.EXE      TBKUTIL.DLL      TBOOK.EXE  						
  6. Rename all the Oem<n>.inf files in the Windows\Inf folder, where <n> is an incremental number starting at 0.

    NOTE: Do not use the oem*.inf wildcard to rename files. Doing so may cause the wrong files to be renamed. For information about rebuilding the driver information database, please see the following article in the Microsoft Knowledge Base:
    ARTICLE-ID: 137377
    TITLE: Removing Windows 3.1 Drivers from Wizard Hardware Lists
  7. If the HP DeskJet Status Monitor is in the Startup group, remove it. To do so, follow these steps:

    1. Use the right mouse button to click the Taskbar, and then click Properties on the menu that appears.
    2. Click the Start Menu Programs tab, and then click Remove.
    3. Double-click the Startup branch to expand it.
    4. Click the HP DeskJet Status Monitor shortcut, and then click Remove.
    5. Click Close.
  8. Restart your computer.
  9. Use the Add Printer Wizard to reinstall the HP DeskJet printer.

    NOTE: Make sure to select the DeskJet driver included with Windows 95, not the Windows 3.x HP printer driver. If the new Deskjet Printer does not show up in the Add New Hardware List, remove the Drvidx.bin and Drvdata.bin files from the Windows\Inf folder. This will cause the Add New Hardware Device Database list to be updated with the new printer.
MORE INFORMATION
For additional information about troubleshooting printing problems inWindows 95, please see the following article in the Microsoft KnowledgeBase:
ARTICLE-ID: 128345 TITLE: Troubleshooting Printing Problems in Windows 95/98
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Properties

Article ID: 137996 - Last Review: 12/04/2015 12:08:30 - Revision: 1.2

Microsoft Windows 95, Microsoft Windows 98 Standard Edition

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