You are currently offline, waiting for your internet to reconnect

WD: How to Create Custom Toolbars and Toolbar Buttons

This article was previously published under Q141995
Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
This article describes how to customize and create toolbars and toolbarbuttons. In Word, you can add, delete, move, or group toolbar buttons tosuit your needs. Word has built-in buttons for menu items, such those onthe File, Edit, View, Insert, Format, Tools, Table, Window, and Help menus.Word also has built-in buttons for Drawing, Borders, and Mail Merge.

You may want to create custom buttons for other commands that do not havebuilt-in buttons; in addition, you can create custom buttons for macros,fonts, AutoText entries, and styles.

How to Add a Button

  1. On the View menu, click Toolbars.
  2. In the Toolbars dialog box, click Customize.
  3. In the Categories list, select the category from which you want to add a button.
  4. Word displays the available built-in buttons for the selected category to the right of the list box.

    For the commands, macros, fonts, AutoText entries, and styles categories, instead of buttons, Word lists the available commands or items in the box to the right of the Categories list in the Commands, Macros, Fonts, AutoText, or Styles box, respectively. Note that the name of this box changes depending on which item is selected in the Categories list.
  5. Click the button you want and drag it to the the location on the toolbar you want.

    Note that if you are selecting an item from a Commands, Macros, Fonts, AutoText, or Styles category, when you select the item, a "ghost" button appears when you hold down the mouse button. Drag this button to where you want the button to go. The Custom Button dialog box is displayed; you can use this dialog box to choose the custom face of the button.
To see a short description of any built-in button's function, click thebutton. Word displays the description in the Description box at thebottom of the dialog box.

How to Change the Image of an Existing Button

  1. Display the toolbar on which the button appears. Click Customize on the Tools menu, and select the Toolbars tab.
  2. On the toolbar, use the right mouse button (Windows) or hold down CTRL (Macintosh) and click the button you want to change.
  3. On the shortcut menu that appears, click Choose Button Image.
If you want to alter the current button face, click Edit in the CustomButton dialog box.

How to Copy or Move a Toolbar Button

  1. On the Tools menu, click Customize.
  2. Select the Toolbars tab.
  3. Use the appropriate procedure from the following table.
          To do this              Use this procedure      ---------------------------------------------------------------------      Move a button          Drag the button to the new location on the                             same toolbar or to another displayed toolbar.      Copy a button          While holding down CTRL, drag the button to      (Windows)              the new location on the same toolbar or to                             another displayed toolbar.      Copy a button          While holding down the OPTION key, drag the      (Macintosh)            button to the new location on the same toolbar                             or to another displayed toolbar.					
  4. Click Close.

How to Create a New Toolbar

  1. On the View menu, click Toolbars.
  2. Select the New button.
  3. In the Toolbar Name box, type a name for the new toolbar.
  4. In the "Make Toolbar Available To" box, click the template where you want to store the toolbar.
  5. Click the OK button.
  6. The Customize dialog box appears.
  7. In the Categories box, click the category that contains the command or other item you want to add to the new toolbar.
  8. Under Buttons, drag the button or other item to the new toolbar.

How to Delete a Custom Toolbar

  1. On the View menu, click Toolbars.
  2. In the Toolbars box, click to select the name of the custom toolbar you want to delete.
  3. Click Delete.

    NOTE: You cannot delete a built-in toolbar. When you select a built-in toolbar in the Toolbars box, the Delete button changes to Reset. Using the Reset button returns the built-in toolbars to their original default appearance.

Moving a Toolbar

To move a toolbar from its "docked" position at the top of the Word window,click a space between buttons and drag the toolbar to a new location. Tomove a "floating" toolbar, click an empty space between buttons or clickthe title bar, and then drag it to the new location.

Use the Organizer to Manage Toolbars

When you create a custom toolbar or edit existing toolbars, the changesare stored in either the Normal template or the template attached to theactive document.

To select where to store the changes, select the desired template in theSave Changes list in the Customize dialog box (on the Tools menu, clickCustomize). Note that this box displays templates other than the Normaltemplate only if another template is attached to the active document. To dothis, click Templates on the File menu. In the Templates dialog box, youcan attach additional templates.

Clicking the Organizer button lets you manage the items stored intemplates, such as styles, AutoText entries, toolbars, and macros. You canuse the Organizer to do the following:

  • Copy items to a template from other templates and documents.
  • Rename and delete items contained within templates.
  • Make macros, AutoText entries, and customized command settings stored in a template available to any document, regardless of the template attached to the document.
For information about how to do this in Word 97 for Windows or Word 98Macintosh Edition, please see the following article here in the MicrosoftKnowledge Base:
155800 WD97: How to Customize, Create, and Restore Word Menus/Toolbars
"Microsoft Word for Windows User's Guide," version 2.0, pages 746-751

Article ID: 141995 - Last Review: 08/17/2005 23:41:14 - Revision: 1.1

  • Microsoft Word 6.0 for Macintosh
  • Microsoft Word 6.01 for Macintosh
  • Microsoft Word 6.01 for Macintosh
  • Microsoft Word 6.0 Standard Edition
  • Microsoft Word 6.0a
  • Microsoft Word 6.0c
  • Microsoft Word 6.0 Standard Edition
  • Microsoft Word 95 Standard Edition
  • Microsoft Word 95a
  • kbfaq kbhowto kbui KB141995