How to Create Task Dependencies Between Project Files

This article was previously published under Q150757
This article has been archived. It is offered "as is" and will no longer be updated.
SUMMARY
Microsoft Project cannot create standard task relationships (predecessor orsuccessor dependencies) across project files. However, tasks can be linkedacross project files to emulate a dependency using OLE or DDE links.
MORE INFORMATION
Linking task dates across project files enables you to set up linked taskrelationships, which may include lead and lag. These linked tasks will notshow linked lines in the Gantt Chart view and will not indicate predecessoror successor numbers in corresponding fields.

The menu selection for creating links between tasks varies in MicrosoftProject versions. For the following example, the source file represents thefile from which data is copied and the target file is the file that the data is copied to. A source task will emulate predecessor behavior and a target task will emulate successor behavior.

Steps to Link Tasks Across Project Files

  1. Create or open two project files. Both files must be open.
  2. In the source file, copy the start or finish date of the source task. To do so, follow these steps:
    1. Click in the start or finish date cell for the source task. Click in the start date if you want to emulate a start-to-start(SS) or start-to-finish(SF) relationship. Click in the finish date if you want to emulate a finish-to-finish(FF) or finish-to-start (FS) relationship.
    2. On the Edit menu, click Copy(Cell).
    3. On the Window menu, click the target file.
  3. In the target file, link the copied date to the successor task. To doso, follow these steps:
    1. Click in the start or finish date of the target task.Click in the start date if you want to emulate a start-to-startor finish-to-start relationship. Click in the finish date if youwant a finish-to-finish or start-to-finish relationship.
    2. On the Edit menu, click Paste Special.
    3. In the Paste Special box, click to select Paste Link, and then click OK.

      The linked date should appear in the selected date field for thetarget task. If in version 4.0 or later, a small triangle will appearin the bottom-right corner of the date cell indicating the cellcontains a link to another location.
To create a link task containing lead or lag, follow these steps:
  1. Create a milestone in the target file.
  2. Link the date from the source task to the milestone date cell.
  3. To include the lead or lag, create a standard dependency between the milestone and the successor task in the target file.
Both files must be saved to maintain the linked task information.

For information about the behavior of Paste Linked dates in a MicrosoftProject, please see the following article in the Microsoft Knowledge Base:
141733How to Build a Hammock Task
REFERENCES
Microsoft Project, version 4.1, "User's Guide," page 21

Microsoft Project, version 4.0, "User's Guide," pages 14-15

Microsoft Project, version 3.0, "User's Reference," pages 40-41, 605-611
4.10
Properties

Article ID: 150757 - Last Review: 12/04/2015 14:40:47 - Revision: 3.0

Microsoft Project 3.0 Standard Edition, Microsoft Project 3.0a, Microsoft Project 4.0 Standard Edition, Microsoft Project 3.0 for Macintosh, Microsoft Project 4.0 for Macintosh

  • kbnosurvey kbarchive KB150757
Feedback